UR01-BLE remote gets unpaired with every reboot

I have an Ugoos AM6B+ with CE running on the microSD card.
I use the UR01-BLE remote that came with the box and paired it (with a PC mouse) in CE.
Unfortunately, after every reboot, the remote is not paired anymore.

Does anyone have any suggestions? :neutral_face:

In my experince BT is hit and miss. I spend so many hours on this issue and never could managed to working properly.

For me, the only solution was to go to system settings and run Reset CoreELEC to defaults. Then, I could repair the remote and it works after reboot.

For me, the error first started when I once rebooted into the NAND from Coreelec. Honestly, it feels like a permission error where CoreELEC cannot write the setting to a file.

@Astrotrain Thanks. I will give that a try.
Do you know in which settings file the paired BT devices will be stored?

Folder holds everything for BT

1 Like

Looks like there is something messed up with owners, groups and permissions.
Unknown user and group with id 1023 where it should be root.

I’m using this, it repairs with a tap of the home button and backlit.


If you set the permission to root, does it work after reboot?

Edit: It seems that 1023 is "1023 is the UID and GID of Android user and group “media_rw” and Android Group Id · GitHub. So, it seems that when you boot into the Ugoos OS, it takes control of these files and prevents CoreELEC from being able to update them.

I’ll give that a try when I’m back at home.

I did that. :confused:

The B21 works perfectly with external usb Bluetooth dongle. Tested with 5.15 and Homatics 4k.

@Astrotrain It worked!
CE created new folders and files which survive a reboot and so does the remote control now.


1 Like

Can someone boot again to Ugoos OS to get wrong permissions and then run this command? It set root owner for all folders and files where root folder is not owned by root user.

find /storage -maxdepth 1 -type d ! -user root -exec chown -R root:root {} \;

I also had issues with connecting my keyboard after a reboot and running a chown command fixed it.

However rebooting into android did not recreate the issue, permissions are still the same.

Although changing the permissions fixed my problem, I still started from scratch with a new CE image on the card.

I also removed the option “reboot from eMMC/NAND” from the CE power menu to not accidentally click it. I don’t see any reason why I’d have to boot to Android.

How did you remove the option?

copy everything from /usr/share/kodi/addons/skin.estuary/ to /storage/.kodi/addons/
then edit /storage/.kodi/addons/skin.estuary/xml/DialogButtonMenu.xml
The XML should be self-explanatory.
under “Reboot from eMMC/NAND”, set visible to False:

	<label>Reboot from eMMC/NAND</label>
1 Like

Thanks, that’s works!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.