USB/TP-Link Archer T2U Nano AC600 issues - Odroid N2

Hi Guys,

I have been using my Odroid N2 with CE 9.2.3 streaming from local NAS (Odroid XU4)

The only way I seem to be able to get this to work is by using a router with OpenWRT in bridge mode and then connecting the Odroid N2 by ethernet cable.

I have tried my TP-Link Archer T2U Nano AC600 in all 4 USB ports at the back and it is detected, but does not auto connect to the network (even though it has been selected and password is saved) also once manually connected it will work for anywhere between 1-15 minutes before either completely crashing CE needing a power off/power on or closing out of the stream.

I dont believe this is a signal issue as it shows over 75% signal strength and I managed to run iperf3 over 200mbps before it crashed.

Is there any logs I can look in to work out what is causing these issues? I do have a Archer T3U device on the way soon but I suspect I may have the same issues if its the same driver?

Crash Log:
Kodi Log:

I am not sure what this is but it seems to repeat a lot at the end of the log:
Jul 07 12:59:00 CoreELEC kernel: asoc-aml-card auge_sound: S/PDIF Playback enable
Jul 07 12:59:00 CoreELEC kernel: asoc-aml-card auge_sound: S/PDIF Playback disable
Jul 07 12:59:00 CoreELEC kernel: spdif_info: rate: 44100, channel status ch0_l:0x100, ch0_r:0x100, ch1_l:0x0, ch1_r:0x0
Jul 07 12:59:00 CoreELEC kernel: hdmitx: err chn setting, must be 2, 4, 6 or 8, Rst as def
Jul 07 12:59:00 CoreELEC kernel: hdmitx: err chn msk, must larger than 0
Jul 07 12:59:00 CoreELEC kernel: aml_spdif_fifo_ctrl, bit depth:16, frddr type:1, toddr:type:1

I am using HDMI audio passthrough and it works fine via ethernet?

I have tried the TP Link Archer T3U Plus which shows as RTL8812BU - not detected in CE stable or nightly releases.

TP Link Archer T2U Nano shows as RTL8812AU - detected in CE but not stable.

Is there any chance to get drivers for RTL8812BU included in a CE build?

Does anyone have a WiFi device recommended for CE that will be stable? I could return these 2 devices.

Can you please provide the output of lsusb

Bus 002 Device 002: ID 05e3:0620 Genesys Logic, Inc.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 2357:011e TP-Link
Bus 001 Device 006: ID 2357:0138 TP-Link
Bus 001 Device 003: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 004: ID 2357:011e TP-Link - This is the T2U Nano
Bus 001 Device 006: ID 2357:0138 TP-Link - This is the T3U Plus

Doing a fresh CE stable build with the T2U Nano and using SMB shares instead of NFS seems to be working much better (I managed to get The Matrix to play completely last night!)

I’ll check the drivers to make sure the id for the t3u plus is included in the driver. I believe it’s a newer device so the driver not knowing about it may be why it’s not recognized.

1 Like

Thank you cdu13a I really appreciate the help

Just to update this post in case anyone in the future is thinking about buying a TP Link Archer T3U Plus or just on the search for a working USB wireless device.

Thanks to the great support from cdu13a the id for T3U plus has been added and I have been running a test build (which I believe is now in the nightly builds) with the device detected and working

I have seen iperf3 results increase from 110/140 Mbits/sec on T2U nano to 220/250 Mbits/sec with the T3U Plus allowing me to watch the majority of my 4K content with no issues - the T2U nano had occasional issues with high bitrate content.

Thanks Corelec for the support! - I now have a great streaming device passing through HD audio, playing 4K content and is even able to run via wireguard vpn with 190mbps download speed all for roughly £100.