Using the internal storage, boot from SD

I’m using a MagicSee N5, installtointernal failed (I don’t care, I wasn’t going to use the Android thing anyway) and now I have an unused storage…

I’m new to CoreELEC, can I delete the existing partitions on mmcblk0 without further consequence? If I create a new partition and mount it somewhere, what file system is recommended?

Also, I noticed there is no fdisk…

You repeated SSH command procedure a second time ?

Pretty sure that is your issue.

I did run the installtointernal command twice but I might have done something wrong, ran it then instead of rebooting, I ran it again.

Do you use a the MagicSee N5 as well?

You don’t just run the command twice whilst the box is still running.
After first running commands i usually power off after finish.
Pull out sd card
Power on without sd card.
If it has failed you will know.
Power off box.
Insert sd card
Power on and run commands the second time.
When finished
Power off.
Pull out sd card.
Power on.
Should Boot.

Thanks for the advice. Indeed that’s not what I did.
I remember trying to restart it after just one run, the screen just stayed black.
What do you mean when you write “you will know”? Am I supposed to see some kind of error message?

That’s what happens on first run.
Power off box after this happens.
Insert SD Card and run commands again.
When finished power off.
Pull out SD Card.
Power on.
Should boot.

Nope, still nothing.
Maybe I’m doing something wrong:

Anyway, any suggestions about re-purposing the internal storage for some extra space?

Can you confirm you had Factory Android ONLY installed on eMMC
with nothing touched from a previous install of CE sharing Android Storage installation ?

I booted into Android just once, just to confirm it’s garbage. There was no other OS besides it, I never tried anything besides CE and I never tried sharing Android Storage with CE. There’s nothing on the eMMC besides previous failed attempts at installing to the internal storage (the first attempt was for the previous version of CE).

BTW, installtointernal uses the active .dtb on the SD right?

If it booted and you ran CE with SD Card Install it should be fine.

I’ve no idea what happened after the SSH session you carried out.

You may have to install Factory Android and start again.

It’s the Risk gone bad for you in installing to internal eMMC.

You knew that so i’m not being smart. :wink:

After the second SSH session I just waited, and waaaaited, then gave up.

I will try to install Factory Android and try again, when I have a lot more time for Magicsee’s junk software…