Very weird - can anybody shed any light?

I have 2 boxes with the exact same hardware - A95X MAX S905x2 boxes with same specs. One box uses a different rom to the other - this is the only difference I can find - both appear to be stock roms and on one box the bluetooth does not work (both have dual wifi/bt chip MT7668). Both roms are Android 8.1 but with different dates.

When CE 19.4 is loaded on both boxes, playback is perfect. When trying CE 19.3, playback on one device is perfect (the device where bluetooth does work) and on the other device (bluetooth does not work), playback consists of fixed vertical red, green and blue lines with dots interspersed - audio is present and ok.

CE is installed on SD card only. Does CE somehow use any part of the Android image for playback??? This is not an issue as such, but I can’t for the life of me figure out why one box plays back perfect at 19.3 and other one does not.

I also went back to older versions of CE and found that both boxes play back perfectly using CE 9.2.5 but from CE 9.2.6 thru 9.2.8, the “bad” box has the same playback issue as CE 19.3.

This is only with hardware decoding - software encoding is fine. All my videos are HEVC 10-bit 720p or 1080p. All videos I have tested behave the same. All videos are stored on external hdd and played via USB cable. This is also using same HDMI cable and TV for playback.

If anybody with experience of developing CE could confirm/deny that the Android image is used in any way to determine playback quality or is there something else I am missing here??

TIA.

They are not the same internal hardware and one configuration is better supported than the other. This is common as either parts substitution or board upgrades happen.
The only way to confirm this is to open the box and take a look.

Shoog

I have looked inside and there are differences. The chip is definitely S905x2, and the board has the same version ‘2018-12-28 A95X MAXV_V81’. The ram chips and the emmc are by different manufacturers and I think the ethernet is RTL8211 in both boxes. Wifi/BT is MT7668.

I don’t know anywhere near enough to see how these can make a difference in playback - especially when both boxes work perfectly with certain versions of CE. If the Android rom is not used in any way during hardware decoding when running CE from SD card, then these manufacturing differences must be the cause as you say.

I also installed cpu-z on both boxes and could not see any differences under any of the tabs (apart from rom version and version of google play services). Versions of java vm, opengl es, kernel architecture and kernel itself were all the same. The kernel version was 4.9.76 on both boxes but this was suffixed differently with a date of 20190109 on the “bad” box and 20190906 on the good box. These dates match the rom dates.

I would like to copy the rom from the good box to the bad box, but the bootloader is locked on both boxes. I can’t find the rom for the good box anywhere on the net. I’ve tried installing TWRP but no joy.

Do you (or anybody) know if it is possible to copy the rom from one box to the other??

I have an A95X MAX and was aware of 2 board revisions, V10 (original) and V81 (revised).

If I remember correctly, the MT7668 (No BT driver for CE) was on the revised V81 but not on the V10.

But you are saying that you have 2 V81’s that have RAM and eMMC from different manufacturers?

I did make a point of collecting all the firmwares (including those from other boxes that are supposed to be compatible), so I will see if I can dig out one for 20190906 so you can try flashing the other box.

It sounds like you either have a 3rd board that nobody has quite recognised as different because the board naming is the same as an existing one, or a clone.

Thanks for the reply. I’d love to get the rom for the 20190906 version and install it on the “bad” box. I’ll attach photos of both boards.


I think these show differences with ram and emmc chips unless I’ve misidentified them. My thinking is if I have the same roms on both boxes, then the playback issue must be caused by some hardware differences as Shoog has said. Just something that’s bugging me as to why one box works and the other doesn’t.

In case you find the 20190906 rom, I seem to recall that flashing any rom to this box requires an extra file separate to the .img file - “SECURE_BOOT_SET” 1kb file is also needed, or the flash doesn’t work - at least for me it doesn’t.

TIA

I have a few images.

20190906

20190109

20190301

20190720

There are a couple of SECURE_BOOT_SET files included to try.

Thanks so much for your help in providing these. You are a gentleman and a scholar!

I’ll try out the 20190906 and hope that’s the one. I’ll let you know as soon as …

Much appreciated!

Well, there’s good news and bad news I suppose. Good news is that my “bad” box is now running firmware 20190906 (same as good box and apparently the latest firmware), and BT is working under android. So, I have 2 fully functioning android boxes. The bad news is that I get the same playback issues (using CE) on the “bad” box as I had before when using the 20190109 android rom. As @Shoog suggested, this must be some funky kind of hardware issue. The different android roms appear to have no impact on CE playback.

All using hardware decoding - software decoding 100% perfect. Using same TV and HDMI cable. (Tried different HDMI cable - same results).

  1. CE 9.2.5 playback perfect on both boxes for HEVC (8 and 10-bit) and H264.
  2. CE 9.2.6, 9.2.7 and 9.2.8 playback perfect on “good” box. Only H264 plays back on “bad” box. (see HEVC image below)
  3. CE 19.4 playback perfect on both boxes for HEVC (8 and 10-bit) and H264.
  4. CE 19.3 playback perfect on “good” box. Only H264 plays back on “bad” box. (see HEVC image below)

I’ve never experienced a case where playback depends on the version of CE with apparently the same boxes.

So, H264 is always good, but HEVC playback is dependent on the version of CE on the “bad” box.

Under android all H264 and HEVC files playback perfectly.

Attached is image shown on the “bad” box with CE 9.2.6, 9.2.7, 9.2.8 or CE 19.3

So, thanks very much for your help and I guess we’ll put this down to a substandard manufacture or a bad clone?? I can’t find any logic as such, but at least quite a few versions of CE do work 100%.

TIA.

Functionality hasn’t really changed across the last few versions of Kodi. I use Leia on my bedroom system and Matrix on my main system. I would have to think hard what additional features the upgrade brought.

My point is - use which ever version works and be happy.

Shoog

Yes, I’m very happy with CE. I’ve never seen before where same boxes with same published specs can produce different playback with the same software.

I was hoping somebody may have seen this before and/or there was a simple reason/solution.

As you say, it has to be some kind of hardware difference under the covers.

A strange one indeed.

Have you tried the latest nightly on the bad box just to see what happens?

Tried it with latest nightly of CE 20 (Nexus). Perfect playback on both boxes - let’s hope it stays that way :grinning:

Had my 19.4 and 19.3 the wrong way round. Perfect playback on CE 19.4 both boxes, but on CE 19.3, playback issue on “bad” box (i.e. HEVC - no, H264 - ok). So it would appear that since CE 19.4 we are back on track.

Great stuff :smiley:

Just an FYI . I have compiled LibreELEC in the past with my own mods and I thought I’d recompile CoreELEC to try and fix this playback issue.

I checked out the 9.2.8 latest Leia version from github and reverted the change for just the one package for the “amlogic media modules” (hardware decoding interface AFAIK) back to the 9.2.5 version. So one very small change and then recompiled this modded version of 9.2.8 and playback is now perfect on the “bad” box and still perfect on the good box. So far, everything else is working fine.

There were a lot of changes between 9.2.5 and 9.2.8, so I thought it worth a try to see if I could stay at 9.2.8 and fix the playback issue. I know this is no longer an issue at 19.4 matrix or later but the A95X max box right now has issues with rebooting when it should power off and at 9.2.8 the dtb you provided works perfectly.

I’d look into providing a UART log to help fix this, but there does not appear to be any CoreELEC SDIO debug boards available.

I have no idea right now when I have time again to create new SDIO boards.

But you can open the box and search the UART header and connect directly a UART/USB converter

Thanks - I’ll see what I can do.