Video calibration lost when actually playing videos

I bought a BeeLink Mini MX III about two years ago, mostly because I was stunned that such a capable little box could be had for only $40 USD.

Of course, I had hoped to be able to use it someday as a reliable and stable full-featured Kodi box, but the last time I seriously checked, in Oct, 2018, I found a whole host of remaining bugs and annoyances. So many in fact that I put the Beelink back on the shelf, hoping that someday, if I waited long enough, the software would mature. Here’s the thread that I started at that time:

I just decided to give this little box another go, after more that a year of waiting and hoping that the many relevant software bugs would get fixed. Today I downloaded CoreELEC 9.2.1 and installed it onto a 16GB microSDXC card, booted the box from that and then tried it out.

Mostly, this is quite good, and the picture quality is excellent. The problem is that, as I noted back in Oct 2018, my specific (bargan basement) TV was deliberately hobbled by the manufacturer (Panasonic) such that it always has a 2.5% overscan on all four sides and there is ABSOLUTELY no way to disable this. (And it makes me REALLY angry when people who don’t even have my exact TV model keep on suggesting this or that “fix” for this problem, none of which actually work.)

The bottom line is that I have use to use video calibration with Kodi. Period full stop. Anybody who wants to argue with me about this is invited over to my house for a live demonstration, followed by a punch in the eye for arrogantly wasting my time with bogus information, yet again.

So anyway, video calibration settings…

Back in Oct 2018, the problem was that CoreELEC was losing the video calibration setting across each power cycle. Now, the problem is a bit different, but it is now even MORE intolerable… and the Beelink has gone back onto the shelf to collect dust, yet again, because of this.

The problem now is that although the video calibration setting does seem to survive power cycles, each time I play a video, if I move the mouse or do anything else to bring up any kind of OSD overlay, as the video is playing, it becomes obvious that the video is playing without being properly scaled as it should be, based on the current video calibration. The OSD overlay bleeds off the edges of the screen. This happens both when using Estuary and when using Confluence. If you then STOP playing the video and go back to some skin menu, all is well again and scaling does occur, but the moment you play a video again, the LACK of proper scaling comes right back.

Sigh. I guess I’ll check back again in the fall of 2020 to see if the quality control on this software has improved any by then. For now, my Beelink remains just a useless brick collecting dust again. I guess that one of these years I’ll just sell the P.O.S. on eBay and maybe get back half of what I spent on it.

Just in case you have these settings in your Panasonic TV.
See attached PDF with possible settings that may solve your issues.
Panasonic Settings.pdf (450.3 KB)

And, what is the exact model number of your Panasonic TV ?

The subs position is lost on reboot. I need my subs to be at 988, but every time have to set from default 1042. What is going on, Kodi?

Do you position subs in global settings or in player settings ?

The Video OSD Menu.

I used to have similar problem and indeed there was a bug in earier versions of Kodi 18 but this is dedinitely fixed now so i’m surprised you still find this problem.

I suggest the following for testing purposes:

  1. Set the default gui resolution to be 1080p @ 59.9 Hz (not 60 hz)
  2. Disable auto frame rate switching
  3. Do your video calibration changes
  4. Do a reset and test…

Try to do it with Estuary skin in Settings/System/Display/Video calibration -> 3rd option is for subtitle position. See here
That should be the global setting for all video formats.

At the risk of getting my post removed. Your attitude sucks and I don’t think you deserve someone spending and time helping you I will try anyhow. I suspect the problem lies between the chair and the remote.

Coreelec and Kodi in general will change video mode to match the video mode of the video when you play your content. As you said you have calibrated the video in the menu, this is probably 1080p@60Hz the problem come when you play your content which will be at a different video mode. You actually need to re-calibrate the screen in each mode so the first time you play a film it may be @ 1080p@23.976Hz your original calibration will not apply to this mode, at this point hit OK on your remote go to settings (the cog) > video > video calibration and set it up. Form then onward you will not need to calibrate again for this video mode again. You then need to redo this for each of the video modes for your content you will probably need to do it about 4 or 5 times.
If you run Kodi on Android mostly the video and frame-rate are scaled to your standard Android video mode. This means you only have to calibrate once but leads to much poorer picture and jumpy video.

Responding to kostaman…

I am not an idiot. I have two degrees, both in Computer Science, which I used to teach, both in college (grad school) and professionally. Trust me. I have been over this and over this and over this and over this. I have CAREFULLY read every last scrap of possibly relevant documentation on my specific TV model. What quite certainly happened is that the pointy-haired boss of some wanker software engineer told the engineer that if he needed to cut something out of the code in order to squeeze it into the tiny PROM space provided by the manufacturing manager, then he should just cut out that part of the code that allows the user to adjust the overscan. So he did, and the option isn’t even in the menus. Period, end.

I really have no idea why people seem to want so desperately to disbelieve me what I say this. I guess that it must only be the people who have never worked as professional software engineers who just can’t seem to grasp the fact that software sometimes has non-features.

Replying to ffimon…

Yes, you’re right. My attitude does suck. It comes from a long history of trying to use Kodi on various platforms, and getting it working just well enough to be tolerable, only to have somebody foolishly break something so that the next release is essentially useless.

If people who work on this code would just stop breaking things from one relaase to te next that would be marevelous.

It’s called regression testing. But I guess the attitude is “That’s what the users are for!”

Now, as regards to your assertion that “You actually need to re-calibrate the screen in each mode…”

In the first place, it would be moronic if that were really true. Why would calibration to fit the screen NOT automatically apply to every mode?

In the second place, I can attest to the fact that this has NEVER been true in the past, e.g. for my other (x86-based) HTPC, running under either OpenELEC or under LibreELEC, and as far as I know, it still is NOT true under either today. (I would know if they changed it. I only have the one flatscreen TV and I would have noticed by now.)

I assure you 100% that for literally YEARS now I have been using this exact same TV and various version of both OpenELEC and LibreELEC and in each case, after a fresh install of a new version… which I have done many many times… I have had to re-do the video calibration after the fresh install exactly and only ONCE and then it has been effective forever after and for all content. Period, end.

Bottom line. Get your facts straight before spreading misinformation.

Please see the following for further information and please note that it doesn’t say a word about your bizzare notion that this has anything at all do do with the specific content being played, or that calibration would ever have to be performed multiple times… which would be ridiculous on the face of it.

I have my facts straight you have to recalibrate for each resolution and frame rate. If you don’t want to do that select change frame for video playback to never. This will meet all your video will be played back at the GUI resolution you probably had that set on your other devices and that’s why it worked. I have come across your ilk plenty of times before convinced Thay are correct and don’t bother.trying the help you were given.
I have set up 23 boxes on. Coreelec and have to go through that process for all the TV’s except where the TV does it automatically by the use of a just scan setting.
Why don’t you give my advise a try and see whether it works

Not working. Tanix TX5 PRO.
Have to change on every restart manually.

It’s a Kodi bug. On some devices it’s present since Kodi v.18.3, so I don’t believe that any anger expressed here will solve the problem…
Here is more info about this bug, that is still not fixed even in latest nightly…

1 Like