Video flickering issues related to resolution (not sure how to title this?)

I don’t know what this video error/glitch is called but I know someone here does, and I need help. This is true for all TV shows, Movies (Blu-ray or normal). In sample video at 11 seconds paused to show how interface has flickering and glitching. Here is video https://www.youtube.com/watch?v=3rlVZ_5Pvcs&feature=youtu.be

Same MINIX NEO box, Same CoreElec Operating System, same cables (and tried 3 cables on 4 different ports for BOTH TV’s), painstakingly tested ALL resolutions with all combos of frame rates with the same flickering issue on both TV’s. New TV has Netflix/Disney+/Amazon Prime built in and on large resolutions it works great (meaning totally separate from MINIX NEO box and KODI). Old TV didn’t have apps “built in” but Roku box does the same thing and resolution is great checking Netflix/Disney+/Amazon Prime (Again separate from MINIX NEO box and KODI). All resolutions/frame rates have this flickering issue EXCEPT 720x480p which is the lowest on list of choices.

After all of that I believe it is some setting/configuration on MINIX NEO box but I have no idea what I am doing wrong. My question is how “high” of a resolution can I go? I would love all the way to 4096x2160p for everything! If that is not possible then where in the list of resolutions (reference video) can I go? On monster new TV it really sucks to have such poor resolution where older 40" was so small it never really matters from across the room.

Specs:
On this MINIX NEO U9-H box (https://www.amazon.com/dp/B06XDPX1JG/?coliid=I1E06HE2G236RN&colid=9FNCSJMECQD8&psc=0&ref_=lv_ov_lig_dp_it)
Runs this OS: CoreElec 9.2.4.2 using build 18.8 (compiled 8-14-2020)
Skin is: Aeon Nox: Silvo skin
OLD TV was 40" Sony Bravia
New TV 75" is this monster LG 8570

If I left out vital information please tell me what it is and also HOW to get it for you as I am a noob. Please help, thank you.

1920x1080p is preferred for the GUI or 3840×2160p if you really want to. Despite the fact that some TVs offer it, 4096x2160p is not the 4k that you are looking for and this will never be the resolution that you want to use. 3840×2160p is the 4k that content is, and will likely also be the native resolution of the TV as well.

1 Like

That looks to me like the UI res is 4K and you have 4K GUI scaling turned off.
Turn it on, reboot and it should fix the issue.

Ok, Thank you for better understanding of 1920x1080p and 3840x2160p. I couldn’t find anything related to “scaling” (maybe it is there an obvious to pro-users but labeled something different so I didn’t know?) but after changing a few settings UI screen was “bigger” than TV monitor. So then I found calibration (I think it was called) to adjust the top/bottom and left/right to manually make display fit TV.

I fear that in future as OS is updated it might check/uncheck one of these settings that fixed my problem and I have to reinvent the wheel again (because I will surely have forgotten how to do it).

So far, we can set this as “SOLVED”.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice