Video hangs for 5 - 8 seconds after a 5 second (or longer) pause

I’m running CoreELEC v9.2.7 on a MECOOL M8S Pro Plus (2GB).
I’m running into a strange problem when pausing video’s. If I pause a video for longer than 5 seconds and unpause the video it will play the audio but the video itself hangs for around 5 - 8 seconds.
After that the video (and audio) continues normally.

I did a search on the forum and noticed a lot more people have this problem but no real solution can be found. Is there anything I can do to fix this? Really annoying.

None one can help me out here?

Just do not pause the movie?

To be honest, you watch movies paused or in normal playback speed?

The explanation for what happens to you with the videos could be the buffers reload time, this is conditioned by many factors and you give no information.

Does the video stream come from a local device, a home network, or the internet?

Do you use WiFi, and on what frequency?

Do you use cache on Kodi, and what kind?

Running CE from flash memory?

@Portisch
Normal playback speed. But yeah, sometimes I need to take a piss and pause the movie. :wink:

@cubimol
Sorry for not being complete.

Video is played on my MECOOL M8S Pro Plus (2GB). All video files are stored on my NAS. On the MECOOL I run CE v9.2.7 on a micro SD card. Within Kodi I use PlexKodiConnect and setup direct paths (smb) to my NAS. I use a cable connection (no wifi). No caching as far as I know.

I had this same setup before with LibreElec v8.x.x which uses Kodi 17(.6) and did not have this problem. If I do a search here on the forum there are a lot more people having this problem but the only “solution” found so far is downgrading to CE v9.2.0 which does not have this issue/problem.

Hopefully this is enough info? Any more info needed please let me know!

[update]
To rule out the Plex integration I have disabled PlexKodiConnect and tested videos directly from SMB share. This gives me the same problem.

When the need to relieve yourself arises, just STOP the video, and it will start orderly when you are ready to resume watching :wink:

I admit i have a similar problem, after a long pause video playback becomes jerky. What i do is i press play, and then i press once the left button which makes the video skip back 10 seconds and playback immediately continues perfectly

Maybe we need to establish a self-help group for users watching movies in pause. :innocent:

@nd299 thx for the reply.
I can do that as workaround.

Though I prefer to have it fixed. I can’t be the only one having this problem.

I don´t know but I don´t have this problem.
Maybe You have a very custimized installation using a lot of Addons etc. using SMB from NAS
IMHO it´s better to use NFS mounted from OS

Do you have a Mecool M8S Pro Plus as well?
Only add-on I use is PlexKodiConnect and even without the add-on I have the same problem (directly playing from SMB).

No, but I have a couple of boxes (S905X, S912, S922X)
There are so much brands :woozy_face:

I have 3 of these Mecool devices (S905X) and they all have the same problem. Clean install of CE v9.2.7 on (micro) SD.

Searching the forum it seems to be related to S905X mostly…
Probably there’s no solution. :frowning:

Same thing on Minix U9-H installed on SD card and local files played from SanDisk Extreme Pro USB 3.0. It started on releases after 9.2.0 and I barely have any add-ons. I did try several releases to see if it worked, but it kept doing the same thing. So I’ve kept the device on 9.2.0 to avoid the issue. I guess I just won’t upgrade until I see the need for a N2+ in the future.

Thanks for chipping in!
Pity to hear though it’s a “common” problem.
Though maybe the devs can do something about it…

Is there a way to downgrade to v9.2.0?

Maybe, but there is no active Development - CE 9.2.7 is EOL

Especially project Amlogic on S912…

But the problem is there since v9.2.1
So it’s not a new problem…

Anyway, EOL…

Feel free to make a PR to solve the issue.

But please stop pushing the post/devs doing the work in free time for free, thank you.

??
I don’t push anyone in here!!
Just trying to resolve an old issue.
If it doesn’t get solved so be it.

I’m enjoying this free software anyways and thankful for the devs making this available.

But I get it… I’ll shut up.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice