Video player crash on Odroid N2+ after upgrade to 19.4

Hi, after upgrading to 19.4 I’ve been experiencing black screen crashes while playing video over an NFS and SMB share. It takes about 20minutes of playing before it crashes, and if I pause the video and resume it will look stuttery.

dmesg dump just after the crash

Odroid n2+ is running from sd card and just connected to Samsung NU7105 tv, controlling via HDMI-CEC and using some random Realtek 5ghz wifi usb adapter

Information about system

------------ /etc/os-release ------------
PRETTY_NAME=“CoreELEC (official): 19.4-Matrix”
------------ /proc/device-tree/coreelec-dt-id ------------
------------ /proc/device-tree/le-dt-id ------------ Not Found!
------------ /proc/cmdline ------------
BOOT_IMAGE=kernel.img boot=UUID=2804-3706 disk=UUID=b7683151-3a83-4072-a3a8-7d63a8f5d013 console=ttyS0,115200 console=tty0 no_console_suspend keymap=fi-latin1 hdmitx=cec7f remotewakeup=0x800f040c decode_type=0x5 remotewakeupmask=0xffff7fff vout=2160p60hz,en logo=osd0,loaded,0x3d800000 frac_rate_policy=0 native_4k_gui=0 hdr_policy=1 quiet systemd.show_status=auto
------------ /storage/.config/boot.hint ------------
------------ /storage/.config/boot.status ------------
------------ /flash/boot.ini ------------

Because of the two link policy for new users.

Debug log dump after reboot and reproducing the issue. This crash took only 3 minutes.
For some reason I couldn’t take a log dump trought the coreElec system ui, it only said “Failed to paste log files, try again”

I think the problem are your MKV files. Looks like ffmpeg do have issues with it. Maybe you share a part of one file what do make issues

Thanks for the reply. I doubt it, as videos that worked just fine previously are also crashing. But here’s 30sec trim of the video that was playing during the debugging.

And when you play the file from local storage or from USB media connected directly to the device?

I think you have a network/share issue:

2022-04-11 20:56:41.361 T:3758    DEBUG <general>: CVideoPlayerVideo::OutputPicture - ttd:-9622ms pts:1971.594 Clock:1981.216 Level:0
2022-04-11 20:56:41.511 T:3757    ERROR <general>: Read - Error( -1, 110, Connection timed out )
2022-04-11 20:56:41.511 T:3757    ERROR <general>: Process - <smb:// Call Saul/Season 5/Better Call Saul - S05E08 - Bagman WEBDL-720p x264 EAC3-AJP69.mkv> source read failed with -1!

Copy a movie like this on local storage and try again if it will make issues. I tried your sample and it played fine without any issue.

Thank you. So it was a network issue after all, but no reason why.
After testing that local video file worked fine, I noticed that 19.4 release had this commit pushed which targeted Realtek RTL8821CU wlan devices. My wifi adapter is Realtek RTL8821CU based so I just unplugged the wifi adapter and plugged it back in and rebooted. I’ve been playing different videos for a whole day, and there has been no dropped frames or disconnections.

Weird problem, but luckily a simple fix.
Thanks for the responses,and thanks for CoreElec!

In the future, always try wired connection when watching from some server. Then you can exclude or confirm wifi problems. And as an advice, if possible always use Ethernet. Wifi won’t handle high bitrate files very well.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.