Video randomly stops playing

Have you made a clean install? From the crashlog it seems that Kodi is trying to high some UI element and crashes during doing that.

Yes, I did about 20 clean installs since I got this board about two weeks ago.

I have exactly the same issue with CoreELEC on N2, starting with all 9.2.0+ releases. Videos randomly stop playing after a while, I get a black screen and after 40-60 seconds regular Kodi interface appears. I have narrowed down the issue to CEC wakeup, so pretty much every time after a wakeup videos stop playing within 20-30 minutes. If I however manually do a full reboot (either via menu or a power cycle) whole Odroid after a wakeup, videos never stop playing even after many hours of playback.

I have been through the logs many times, did quite a few reinstalls, tried with eMMC and SD card and it’s happening over and over again. I have also tried installing Android for N2 and tried Kodi for Android and that same issue doesn’t exist there, videos never stop playing.

Let me know if I can provide any more information.

Have you tried completely to disable all CEC functions in “config.ini”, in Kodi Settings - Peripherals and in Kodi CoreElec settings?
A debug log after it happens would tell more…

Thanks for both your reply’s. I don’t use and have disabled from the start CEC both on the N2 and my TV. On the N2 i did it in Kodi Settings - Peripherals and in CoreElec settings but in CoreElec settings changes don’t seem to stick. Thought maybe because I disabled CEC in Kodi Settings - Peripherals. About config.ini, do you mean in /flash? If so i don’t see where I can disable CEC functions.

But thing is I did some short test with USB HDD and then it seems to work fine but need more testing to know for sure. I also changed network switch to test but that did nothing to solve it. But I’m pretty sure it isn’t my network anyway because RPi’s work fine and so do all other devices on my network, but couldn’t hurt to try.

Also tried to set buffer to 300MB in advancedsettings.xml but no luck there.

Now I’m writing Android to SD to test that, so thanks for that tip kreatormoo because I was running out of things I could think of to test. I will let you know how that goes.

1 Like

Yes, in config.ini in /flash, after the section # HDMI CEC Control put the command:
cec_func_config=0 which I believe completely disables CEC functions.
(or is it cec_func_config=‘0’, not sure about apostrophe)

Oke, will check that out later when I flash back my backup of CoreELEC.

Other question. Is it possible to install Play Store on android? And is there an Android TV image for the N2?

All about N2 Android images, PIE-Tablet and PIE ATV version, see here
For all N2 official PIE 32/64 bit versions see here

Thanks, will check that out. Hopefully I will find a good Android TV image because the official Android sucks for navigation on TV.

On my N2 ive seen this behaviour with 9.2.2 and 9.2.3. For me 9.2.1 works ok.
9.2.2 and 9.2.3 work fine on my C2.

Just tried installing 9.2.1 twice but N2 won’t boot. No flashing blue light just continues red light.

Tried 9.2.0 but also doesn’t boot. Could it be because I have 2GB N2 with new memory configuration like mentioned here ?

9.2.2 and up do boot and they are released after that announcement.

don’t know, but i read coreelec is less safe then libreelec. Libreelec is better protected on the internet. Then corelec has more advanced features and support. I had a computer which had the spectre bug, so hackers could turn off your pc. So it isn’t completely impossible.

Where did you read that “coreelec is less safe then libreelec”?

So far with fully disabled CEC (cec_func_config=‘0’) the issue didn’t reappear, so it seems we have confirmed it’s CEC-related.

Can’t remember where. When i first wanted to install an just enough kodi os, i read about libreelec vs coreelec. Coreelec had more features and was more up to date, but libreelec was safer online to use.

Unfortunately, cec_func_config=‘0’ doesn’t work for me.

For me it does seem to have something to do with network. Have tested some more with USB HDD and it doesn’t seem to happen then.

I have changed network switch, cables, SMB to NFS and tried streaming from a Windows 10 Pro share instead of my NAS to test if somethings wrong in my network setup but that made no difference. Add to that none of my other media devices have any problems I’m pretty sure the fault isn’t in my network.

For what ever reason audio seems to stall/go out of sync according to kodi.log and playback stops.

2020-07-03 20:10:10.699 T:3596600192 NOTICE: CVideoPlayerAudio::Process - stream stalled
2020-07-03 20:10:32.431 T:3458880384 ERROR: Read - Error( -1, 110, Connection timed out )
2020-07-03 20:10:32.433 T:3458880384 NOTICE: CVideoPlayer::OnExit()
2020-07-03 20:10:32.433 T:3458880384 NOTICE: VideoPlayer: eof, waiting for queues to empty
2020-07-03 20:10:32.433 T:3458880384 NOTICE: Closing stream player 1
2020-07-03 20:10:32.433 T:3458880384 NOTICE: CDVDMessageQueue(audio)::WaitUntilEmpty
2020-07-03 20:10:32.433 T:3458880384 NOTICE: Waiting for audio thread to exit
2020-07-03 20:10:32.433 T:3596600192 ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
2020-07-03 20:10:32.433 T:3596600192 NOTICE: thread end: CVideoPlayerAudio::OnExit()
2020-07-03 20:10:32.433 T:3458880384 NOTICE: Closing audio device
2020-07-03 20:10:32.438 T:4037481344 WARNING: ActiveAE - large audio sync error: -21366.722013
2020-07-03 20:10:32.439 T:3458880384 NOTICE: Deleting audio codec
2020-07-03 20:10:32.439 T:3458880384 NOTICE: Closing stream player 2
2020-07-03 20:10:32.439 T:3458880384 NOTICE: CDVDMessageQueue(video)::WaitUntilEmpty
2020-07-03 20:10:33.221 T:3458880384 NOTICE: waiting for video thread to exit
2020-07-03 20:10:33.222 T:3509236608 ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
2020-07-03 20:10:33.222 T:3509236608 NOTICE: thread end: video_thread
2020-07-03 20:10:33.222 T:3458880384 NOTICE: deleting video codec
2020-07-03 20:10:33.226 T:3458880384 NOTICE: Closing stream player 3
2020-07-03 20:11:05.134 T:4059274688 NOTICE: CVideoPlayer::CloseFile()
2020-07-03 20:11:05.134 T:4059274688 NOTICE: VideoPlayer: waiting for threads to exit
2020-07-03 20:11:05.134 T:4059274688 NOTICE: VideoPlayer: finished waiting
2020-07-03 20:11:05.134 T:4059274688 NOTICE: CVideoPlayer::CloseFile()
2020-07-03 20:11:05.135 T:4059274688 NOTICE: VideoPlayer: waiting for threads to exit
2020-07-03 20:11:05.135 T:4059274688 NOTICE: VideoPlayer: finished waiting

So I tested some more and it seems cec_func_config=‘0’ doesn’t stick in /flash/config.ini because it’s read-only file sytem. How can I make changes to this file? Tried doing it with nano through ssh.

I honestly have no clue what you’re talking about.
Besides, CE is designed for Amlogic chips, not x86.

Put the card in a PC and do it there with Notepad++