Video stops playing (S905)

I installed the newest coreelec on my KII PRO (S905), and connected it to my new 4k tv. When I stream a video file (usually 1080p hevc 10bit files), after a while (could be 10 minutes, could be half an hour) the video stops playing (even though it has buffering cache to play).
I tried an older coreelec version, and even a libre one, and the issue is the same.
I have adjustable refresh rate on start/stop.
I have a high speed HDMI cable (it’s the one that came with my Dell 1080p monitor).

I do not experience the same issue with another 1080p monitor I have.

I took a debug log file, but was unable to paste it though settings, so I uploaded it on gdrive
(here’s the link

ANY help would be greatly appreciated, cause it’s driving me nuts, cause otherwise it’s smooth as butter, even on a gui display setting of 4k 60fps (I have it as recommended on 1080p though)!

(Sorry for the double post, it’s also posted on help & support/coreelec, it’s my first one and. I’m nervous. If it’s not ok please delete one of the two)

I did a hard reset, and reproduced the issue, taking log properly this time. If anyone could take a look at it

It’s my first post too… I had a similar issue where the video stops playing, also in in my case if I used the forward and backwards buttons this could cause the streaming to lockup, stop etc.

Also, certain video files were more susceptible than other and it made no sense.

My setup that cause this issue was as as follows…

A95X-BN7 wireless connect to a router running openwrt, the router has a hard disk connected to usb port where moves etc are stored.

I see that you have added an advanced setting file,


The buffer mode is set to 1 Buffer all filesystems, both internet and local

The issue I had was fixed when I change this buffer mode to 2 Only buffer true internet filesystems (streams) (http, etc.)
I accidentely found this and have had no issues for four days now

I also have a slow windows box running kodi connect to another TV, the same mod worked on this box

You could try and let us know

1 Like

Thank you for your reply. Do you think this might help with the streaming? Because I only stream videos, I rarely play something local.

So this issue only occurs when streaming content from the internet… Does not seem like the same issue then… The above change will still add video buffer cache for for internet streams

There is a Enable HEVC workaround in setting
Settings -> System -> set to Expert -> CoreELEC -> Enable HEVC workaround
(Not sure this will help you could give it a go )

1 Like

I have hevc workaround on, that’s why I’m going insane… I’m playing a local hevc right now, I’ll report back.

@alexxkidd I deleted your other topic.
I asked you to do a fresh install.
Your logs here show pirate addons used for playback.

2019-12-04 00:54:04.387 T:4090056720 NOTICE: ADDON: v9.2 installed
2019-12-04 00:54:04.387 T:4090056720 NOTICE: ADDON: v1.4.8 installed
2019-12-04 00:54:08.432 T:3885110144 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
Error Type: <type ‘exceptions.ImportError’>
Error Contents: No module named bs4
Traceback (most recent call last):
File “/storage/.kodi/addons/”, line 8, in
from resources.lib.modules.trakt_sync.activities import TraktSyncDatabase
File “/storage/.kodi/addons/”, line 3, in
from resources.lib.modules.trakt_sync import shows
File “/storage/.kodi/addons/”, line 6, in
from resources.lib.indexers import trakt, imdb, tmdb
File “/storage/.kodi/addons/”, line 8, in
from bs4 import BeautifulSoup, SoupStrainer
ImportError: No module named bs4
–>End of Python script error report<–