VIM2 can't boot with CE on SD card

Hey folks.

I’m trying to test CE on my Khadas VIM2 Pro and somehow I’m not able to boot it.

Currently my box is running Android on eMMC and I’m able to boot LibreELEC from SD card. However if I write CoreELEC on the same SD card my VIM2 simply ignores such card and starts internal Android like there was no SD card at all.

I think it has nothing to do with dtb.img since I used CoreELEC-Amlogic.arm-9.0.1-KVIM2.img image which is dedicated to my device but just to make sure I also tried to overwrite dtb.img with gxm_kvim2.dtb and it still doesn’t work.

Not sure what to do next. I suppose my problems are related to u-boot stuff which is kinda mysterious for me. LibreELEC images come with aml_autoscript.zip script which I’m able to load from Android and force my box to boot from external disk. CoreELEC doesn’t have such script included and maybe that’s the problem here? Any hints what else can I try to launch my box with CE?

regards
Bartek

Anyone? I’d really like to test CoreELEC on SD card / USB stick before I put it on eMMC.

Are you following special boot into SD method for Khadas Vim2 Basically to boot into coreELEC for the 1st time you need to press and hold power and reset buttons before connecting power to VIM2. Then you need to release reset button but hold the power button for approx 10 seconds then release and corelec should boot and finish its install onto SD and enter Kodi GUI. Now you should be able to switch between coreELEC via kodi GUI on SD and Android GUI on emmc. (Addtional options should be available in both OS as well as normal switch off and/or reboot options)

By the way I am switching between libreELEC and coreELEC both written to different SD’s so it should work. (I have not messed about with any dtb files)

Works for my Khadas VIM2 Pro :wink:

I use Windows “LibreELEC USB-SD Creator” to write coreELEC to SD (manual method)

Make sure you select correct CoreELEC download for Khadas VIM2 for intial installation on your SD

The latest coreELEC guidance in above link on which download to select for a new installation based on your VIM2 and graphic memory based on VIM2 model you own is very helpful now :slight_smile:

When I use special boot I end up in Android Recovery.
Then among options I can choose reboot to bootloader or reboot to system.
Reboot to bootloader ends up with just Khadas logo.
Reboot to system ends up with booting internal Android.

I’ve just tried new guidance to select image but I ended up with the same image I manually chosen before so I guess that’s not a problem here.

Downloading now LibreELEC USB-SD-Creator to try different soft to write image. I was using Etcher previously (and before that simple dd but I was told to avoid it).

Hmm which version of libreELEC have you been using on your VIM2 as i thought there were no stable version based on Kodi Leia, I have been sticking with CoreELEC for general daily use as very stable and I am happy with it and I have been trying latest experimental versions of LibreELEC "with unstable panfrost graphics from this Link

Note: Librelec 20190304 build (currently available in above link) is not stable for longer than few minutes (Just gives an impression of latest staus regarding panfrost graphics drivers with latest nightly builds of LibreELEC)

I’m using the one you mentioned… and there is a reason I’m trying to switch to something different right? :slight_smile:
I also noticed that LibreELEC is unstable and that’s why I’m trying to run CoreELEC instead.

I’ve just tried to use LibreELEC USB-SD-Creator to write an image to SD card and the results are the same.

I think (but that’s just my humble assumption) that by running LibreELEC and its aml_autoupdate script somehow I changed u-boot (u-boot-2018?) settings and now just LibreELEC images are being able to boot. CoreELEC doesn’t want to boot no matter what I’m trying to do.

Any idea how to fix bootloader? How to restore it to the stock version? Preferably without need to flash whole eMMC with stock rom. Maybe some dd command to clear some part of u-boot?
I’m not u-boot expert so I’m just guessing that this is something which is currently broken - or maybe better word is modified to comply just with LibreELEC.

Enabling aml_autoupdate script is an area I have not knowningly performed on my VIM2, so not sure how to help resolve issue relating to this or any modification to multi-boot feature to only currently work with version of LibreELEC you have installed on your SD?

Hopefully someone here more knowledgeble on boot-up methods, can guide you on how to ensure latest version of CoreELEC is recognised on SD at boot-up of your VIM2.

Can you try the Generic image as this contains the autoscript file and copy gxm_kvim2.dtb to the root folder and rename it to dtb.img.

Odd… I have the EXACT same issue! (Well except my box is Vim1… and it’s new, I wasnt using Libreelec on it before)… All I can achieve is to boot to Android recovery…

If my cat can leave me in peace for 10 mins I will try the generic image with the dtb for my vim1

It will probably be the exact same issue, if your using one of the KVIM images then I have uploaded the aml_autoscript here, just download the file and pop it in the root folder of your sdcard and let me know the results.

1 Like

Thanks! That worked!

Thanks for the feedback I’ve updated the source for the next release.

Yeah now works perfectly! :wink:
I think topic can be closed.

Thanks a lot to everyone involved.

Guys, i simply can’t manage to get it to boot. These are the things that i i have done

  • I have put Android on the NAND and CE on the micro-sdcard.

  • I have downloaded the aml_autoscript from https://test.coreelec.org/ and put it on the COREELEC partition where the device tree folder is also located. I have put it in the root folder.

  • I have copied the dtb files from the devicetree to the root/renamed and both of them still don’t change the game.

  • The system can boot in to Android, when i hold down powerbutton, then press reset button, i don’t get anything on my monitor. I have connected it to my laptop, so through burning tool, i KNOW it has gone in to recovery mode as burning tool sees it has been connected. However, not being able to boot from the sd-card.

Any help?:

I have found the answer why it did not boot in to the sd-card. =_=!

WARNING: Don’t use your PC as the USB-Host to supply the electrical power, lest it will fail to activate Multi-Boot!

About | FAQ | Terms of Service | Privacy Policy | Legal Notice