VIM3 + M2X + NVMe

Is it possible to use a VIM3 with an NVMe drive and move the storage partition to said drive?

Over the M.2 interface? This supported but you loose Gbit.

Yep, M.2. Are there any instructions anywhere for this?

I can activate PCIe mode using:- PCIe/USB3.0 Port | Khadas Documentation

But how do I format the drive and move the storage partition to it?

Do you know how to set it up then?

No, one user on forum requested it. It’s implemented in CE settings.

I can’t find it in CE settings, all I have is Wired Network Interface default or M.2. Nothing about NVMe storage :frowning:

Can you ssh into the device to verify that it is recognizing the NVME device before we go any further.

ls /dev/nvme*

if the drive is there this should return something like /dev/nvme0 for the device and 0 or more entries for any partitions on it.

No, I’ve now tried two different drives, both of which I know work and neither are listed under /dev/nvme*

I’ll take a closer look. I don’t think any of the devs actually have the M2X board and an NVME drive to test with, so it’s possible that it either got over looked or got lost a long the way.

Thanks. Just as a side note I’ve also tried the NVMe drives directly into the VIM3 to rule out any issues with the M2X board, still nothing detected.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice