Vim3 playback issue on LG TV uf7787

Hi,
I do not know when it appeared, but for a few days I noticed some shadows (I do not know what the technical term is, I hope you understand from the pictures) on some videos run from my vim3, on a slightly older TV lg uf7787. On another TV (philips pus55xxxx) it looks good.
So, on LG uf7787 on Vim3 pro shadows do not appear, on x96 max s905x3 shadows do not appear.
I used the same cable, the same hdmi port (hdmi 1), the same test video file. You can see the difference in the following pictures.
The test video was LG New York HDR UHD 4K Demo.ts and can be downloaded from here: https://4kmedia.org/lg-new-york-hdr-uhd-4k-demo/
I tried CE nightly, CE stable installed on clean on sd and android on emmc. Also, you can see the shadows from android, and with kodi and another player. Android version VIM3_PIE_20200103.
On another newer TV, philips pus55xxxx the image is ok, it is viewed correctly from vim3 and from x96.
Could it be a codec incompatibility problem?

That’s Color Banding otherwise known as Posterization. You say the Lg’s an older model? Does it even support HDR?

In CoreELEC try going to Settings -> System -> CoreELEC and turn on “Limit display colour depth to 8-bit” Then reboot the box and see if it makes a difference.

it is not hdr tv, at least there is no logo with hdr, the model being a little earlier than hdr era, but the same panel was used in some later models. this problem has not always been, and on the same TV the x96 box show the image correctly without limiting the color depth to 8 bits. until about two months ago he shows me the colourimetry as bt. 2020 on hdr videos but after an update only shows me bt. 709. this I think was through January-February.
I tried now with the 8 bits limit, without any effect, the image looks the same, with shadows.

It’s weird that Android does the same thing, with other player, which allows me to choose other codec (OXMC), but it seems that the shadows are less pronounced.

This problem is because you’re trying to play a HDR video on a non-HDR TV.
It’s difficult to do proper tone mapping to map HDR to SDR, which is the mode you see on your LG.
There’s not much we can do about it.

yes, I believe what you say, but on x96 it works fine. and from vim3 it went well also, up to a point. i don’t know if the problem did not appear after i installed android on emmc and CE on sd. before I had only CE installed on emmc. Do you think that if I would remove android from the emmc and install an older version of CE that I would work for nothing, or have any chance of success?

well, I discovered something. i deleted android and installed CE 9.2.1 officially from khadas with the krescue utility. at the first attempt, without changing the default settings, the image looks the same as before with shadows. in settings was activated hdr to sdr on. after I deactivated, I turned off and rebooted, the shadows disappeared, and the clourimetry is bt.2020 even though eotf is SDR, not HDR. Is there an automatic detection somewhere for hdr and non hdr TVs and it doesn’t change manually from hdr to sdr settings or vice versa that nothing changes?

It’s possible that your TV supports BT.2020 color space, but doesn’t support HDR.
Don’t you see an option to enable/disable HDR to SDR in nightly builds?

the option exists, but nothing happens. no matter how it is set on or off, the image is the same. from vim3 it looks bad, from x96 it looks good.
a little disappointing.
vim3 looks worse than a four times cheaper box at this point for now. on android and CE.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice