VIM3L Krescue 9.2.5 image

Hi all
Can someone provide me a Krescue eMMC image (preferably with empty /storage) of a VIM3L running Official CE 9.2.5 from eMMC?
Reason being: I have a VIM3L (HTPC Kit) running preinstalled Khadas CE 9.2.5 from eMMC, but, I have been told in other thread (CoreELEC 19 Matrix Discussion) that Khadas and Official (i.e. Normal) installation are not compatible. For example: Official eMMC installation (done with ceemc) has /storage/dtb.img but Khadas eMMC installation has not. But, this is a requirement to test Matrix beta build.
In any case, eventually I would like to have an installation in eMMC compatible with Official if only to become independent from Khadas updates/upgrades.
I tried various ways to install Official CE 9.2.5 in eMMC. These attempts are documented in other thread (and also on Khadas forum), but, so far, they failed for various reasons.
Therefore a Krescue eMMC image could be a life and time changer. I know krescue images based installations are not supported, but, for now I see no easier way to migrate from Khadas to Official CE 9.2.5 in eMMC.
fwiw: Krescue V1.0 has just been released, so, if making an image, consider using V1.0

The Khadas devices are easily managed using the usb-c cable and amlogic burning tool all provided by Khadas. It’s a 5 mins thing.
I recently tested exactly that with Krescue and ran into the same problems. So I just burned an android imagem, booted from uSD and used ceemmc to run CE from emmc. It works. Forget about Krescue.
If you want we can go for it, step by step in here.

1 Like

@Vascobraga

It is indeed a 5 mins thing, I know the Khadas varios tools and I tried them all.
So I also tried amlogic burning tool (from ubuntu) and image VIM3L_Pie_V201113.7z. It installed and booted into Android, and I could boot CE 9.2.5 from external SD as well, but emmc did not work…

CoreELEC:~ # ceemmc

Starting CoreELEC eMMC installation tool...

eMMC size: 0x0003a3e00000 [16GB]

No CoreELEC installation found on eMMC

Install in dual boot mode, CoreELEC and Android on eMMC
  Use CoreELEC data from
    [1] current used SD or USB device
    [2] existing backup on current used SD or USB device

Install in single boot mode, only CoreELEC on eMMC
  Use CoreELEC data from
    [3] current used SD or USB device
    [4] existing backup on current used SD or USB device

Please choose one option? [1/2/3/4]: 3

Free space of 'partition CE_FLASH': 512MB
Warning: Could not find 'dto' partition!
Free space of 'partition CE_STORAGE': 14298MB

Used space of '/flash': 222MB
Used space of '/storage': 3MB

There is enough free space on eMMC for installation!

Install CoreELEC on eMMC.
Continue? [y]: y
Error dtb magic: !
Could not remove node '/partitions' from dtb0!
Failed to write the new partition table to eMMC!

Try another Android image. I remember something is bad in last one/two Khadas images.

1 Like

thanks @Portisch

@Vascobraga,

  • which exact Android VIM3L image did you flash?

  • did you flash from Linux or Windows?
    if from Linux,
    did you use command
    aml-burn-tool -b VIM3 -i update.img
    ?

I flashed from windows and used VIM3L_Pie_V200320

1 Like

I have no windows, thanks for the exact image name, I will try it
note that I use -b VIM3 because
aml-burn-tool -b VIM3L -i update.img
ERROR: Unsupported board: [VIM3L]
perhaps this is an issue
anyway, I keep you informed
in worst case I find someone running windows

I’ll run some test with ubuntu in next few days.

No need to test further, mission completed (replacing Khadas CE 9.2.5 in eMMC with Official one) using VIM3L_Pie_V200320 :slight_smile:
Kvim3L-CE:~ # ls /flash/dtb.img
/flash/dtb.img
The problem must have been the latest Android image.
Thanks for great support and empathy

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice