Vorke Z6 Plus [S912] does not install/boot Coreelec 9.2 (nightly too)

Hello alltogether!

As I love Coreelec already für long time running on a x96 Mini, i was searching for 4k capable cheap hardware.
I got a Vorke Z6 plus and tried to install/boot Coreelec 9.2, but I failed and I would like to kindly ask the community for help.

I did, what I always do when I install Coreelec on a “virgin” device:

  1. Downloaded : CoreELEC-Amlogic.arm-9.2.0-Generic.img.gz
  2. flashed that image onto a microsd card using rufus.
  3. copied the “gxm_q201_3g” (According the https://coreelec.org/dtb/ that should be the correct file) to the root directory of that microsd card
  4. renamed that file to dtb.img
  5. inserted memory card into device
  6. boot from memory card

That always happens:
First redish Screen of CoreElec appears and there are some textlines located at the upper left corner saying coreelec is making some installstuff repartitioning tables or somthing like that, but no errormessage. After 15 Seconds countdown the device reboots.
After reboot the device hangs in a bootloop, or at least the display says “boot” and screen stays black.

Android Stocksoftware works w/o problems, so I assume there should not be hardware issues.
Tried another memorycard, just to make sure its not the media
Tried nightlie build.
Tried even other dtb-files: Vorke Z6 (without “plus”), some others from the internet

Always same behaviour.
Is the “Vorke Z6 Plus” really supported by Coreelec?
BTW: I also failed installing Libreelec, same behaviour.

Is there a bootlock or other things to consider at Vorke Z6 plus?
I hope you can help me installing my favourite Mediacenter.
Looking forward to hearing from you.

best regards,

Did you try 2g DTBs?

up to now I did not try 2g variants. But I will do and report. Do you think there are maybe fraudolend 2g devices sold as 3g?

best regards,

There are definitely such devices out there, but I can’t remember if I ever saw specifically Vorke Z6 with fake RAM.

Hi I am using a Vorke Z6 Plus without problems. But I note that there is a Vorke Z6 and a Vorke Z6 Plus. In downloads, each has a different dtb file.

But for myself I have always used the one for the Z6, not the Z6 Plus (even though I have the Z6 Plus).
Try if that helps

I tried various versions. Nothing works.
I am running out of ideas. Maybe the device is not ok.

I think I will sell this device and buy another 912 one that is capable displaying 4k@60fps.

best regards,

You can also try to install 9.0.3 version.
If it works then update to latest after.

I would advise against S912. It’s an old and obsolete platform.
If you’re buying something new, it should be S922X or S905X2 based.

Thank you for your replies.
I tried 9.0.0, 9.0.1, 9.2, and 9.2 nightlies.

Lets say i can get hold of a working device with internal installation.
I remember me logging into a device using putty ages ago and fiddling arround the console. But I have no clue, where to search a dtb.img in the filesystem.
Is there a way to exctract the used dtb.img or at least to determine which one is used?

best regards,

I might got a last idea. Can I just extract the dtb thats currently used by android and use that for coreelec?
A description is here:

But are they compatible?

best regards,

I was finally able to identify and solve the error.
Just for future Information and as a service to public:
The root of all problems was a obviously too long HDMI cable.
During installationprocess of Coreelec and first few seconds of booting there is a screenresolution, that was low enough to pass that cable without noteable problems. Television displayed everything that came from the box.
But when Coreelecs welcomescreen appears, the resolution switches to 4k (maybe due a 4k TV) and for this resolution the cable had too much errorinfluence or is not certified for 4k. Thats why the screen went always black when finishing booting.

In desperate used a shorter cable (had to move some furniture to get access to a powerplug) and voila it worked.

I wish to thank you all for your good advices and help.

Case can be closed.

best regards,

One more small additional info: i had to use gxm_q201_3g_1gbit to have wired network working.