VPN - Tailscale - Entware

If you are wanting an easy way to connect your devices like they are on the same LAN even know that they are on different LAN’s, or you are away from home.

Then look to Tailscale.

I use it myself and I can easy connect to my TVheadend server (running on Odroid C4 on Coreelec) and NAS both running Tailscale from my laptop also running Tailscale also - I just use the IP addr given to my device from Tailscale and it just works.
I can even share a device with a friend (if he is using tailscale).
You first need to add entware and from there you can install Tailscale.

You can even run it on your router.

https://discourse.coreelec.org/t/what-is-entware-and-how-to-install-uninstall-it/1149

https://tailscale.com/kb/install/

https://www.youtube.com/watch?v=bcRVkoeSN0E&t=3s

https://github.com/Entware/Entware/wiki

1 Like

great, you did it with TailScale
Subnet routers and traffic relay nodes? I can’t see any other devices on the network.

You need 2 or more devices with Tailscale for this 2 work.

Got it. I have 4 devices on CoreElec which I can access via TailScale but when I enter the IP eg my smart TV I can’t get to it

I also enabled net.ipv4.ip_forward = 1

or did I misunderstand how it works? and can I only see devices that are directly connected to that device?

I don’t use Tailscale but I have no problem using my own VPN networks (Main: WireGuard and Auxiliary: ZeroTier) and turning my CoreELEC devices into network bridges to access internal subnets 192.168.0.0/16. For this it is enough to include the following code in /storage/.config/autostart.sh

  sysctl -w net.ipv4.ip_forward=1
  sysctl -w net.ipv4.conf.all.forwarding=1
  sysctl -w net.ipv6.conf.all.forwarding=1
  sysctl -w net.ipv4.conf.all.rp_filter=2
  iptables -t nat -A POSTROUTING -j MASQUERADE
  iptables -A FORWARD -i wg+ -j ACCEPT
  iptables -A FORWARD -i zt+ -j ACCEPT
  iptables -A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT

obviously I use different domains in each home subnet 192.168.0.0/24, 192.168.1.0/24, 192.168.2.0/24, …

amazing, this worked. thanks a lot

Great you got it working :slight_smile:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice