Wetek Play 2 - unable to start

Hi, i’m unable to make coreelec work on my wetek play 2.
These are the steps i follow:

  • download CoreELEC-S905.arm- and gunzip;
  • burn the .img to an sd card using etcher (on macOS)
  • in the sd card, copy /device_trees/sgxbb_p200_2G_wetek_play_2.dtb to /dtb.img
  • shutdown and disconnect power cable from the wetek play 2
  • insert sd card, press (and keep pressed for 8/10 secs) the “upgrade” pin on the bottom and connect the power cable

The system boots correctly from the sd card, and i see a nice coreelec logo with a warning in the top left corner: (image removed, new users can only put one image per post)

After 60 secs the kernel boot start. Just a couple seconds in, a see a really long dump looking like a kernel trace, a fatal error “Failed to load kernel modules”, and then the system hangs soon after the “Starting Unbind framebuffer console…”:

I’ve tried to

  • use a different sd card (samsung 32gb u1, kingston 4gb c4)
  • use a different coreelec version (8.95.3, 8.95.2)
  • use a different software to burn the sd (libreelec USB-SD creator)

Other info:

  • the system is connected via wired ethernet, i see the lights blinking but the wetek play can’t be seen in the router’s dhcp leases page
  • the wetek play 2 has a dvb-t2 tuner plugged in
  • i normally have an usb keyboard plugged in, but also tried disconnecting it
  • the wetek is currently running official libreelec 8.2.5 from nand.

What can i do to fix it? Thank you for your time

So, i made a video of the boot sequence and here’s the frame where the crash starts:

Why did you press the reset button on the bottom of your WP2?
This is only needed for hard recovery operations, but not for dual boot. You just need to press the power button on your remote once (while the “wetek” logo is showing up) to switch between sd card and nand boot.
Also, your image is showing the boot process of LibreELEC instead of CoreELEC.

1 Like

I pressed the reset button following the “toothpick method” as described at How to install CoreELEC. Now I know that I need to use the “menu button” method, thank you for this info.

You can’t see it in the image, but the boot is from a coreelec sdcard (with the coreelec logo, as shown in the first post). Looking at the log, it looks like it’s trying to load the kernel (or kernel modules?) from the nand-installed libreelec instead of from the sdcard. This obviously fails.

I’ll try to remove libreelec from the nand and see if it works, thank you

Yeah, something is messed up badly (maybe because of the tooth pick method).
Your last screenshot shows “LibreELEC (official): 8.2.5”.
Just re-install your SD card with CE and try to cleanly boot from it (without the tooth pick method).
You can install it later to your NAND using “installtointernal” in SSH.

1 Like

I tried using the “menu button” method, coreelec booted fine from the sdcard.
Thank you @relkai!

1 Like

You are welcome, @ctrlaltca
Great news, that you solved the problem.