Where do I place a downloaded remote .hwdb file?

I have no idea now if this is the right place to post this but I am pulling my hair out. I have never had any problem with the IR remote.cfg files installing in the .config folder. But I just am helping a friend install CoreELEC 20.2 -ng to his new Ugoos X4Q Pro box and it has come with a different remote which is not the same as my Ugoos X4 Pro remote. This one is clearly BlueTooth and I have looked for a remote config file for it but only one I find is for Bluetooth remotes for this box and the file I have downloaded is UR01_BLE.hwdb

I have l searched high and low and only place I can see where to install it is in the .config/hwdb-d folder but it still will not work ?? So clearly this needs to go somewhere else. Why has this become so much more difficult than the old reliable IR remote.cfg system? Wasted over an hour of time trying to sort this and now very frustrated. Please can anyone help

PS UPDATE. I have now found out it does work but ONLY after I pair the remote BT with the COREelec box. However to my utter horror and frustration when i reboot the box the pairing disappears and you have to repair every time you reboot the box. Even tried Trust and Connect which I thought might remember the pairing but NO it does not. That is utterly unworkable. When I have paired it I notice the menu button does not work with this hwdb file ?? Looks like I will have to get my friend to order a decent Ugoos IR remote which works perfectly as I have with with my older X4 Pro box

Why oh why do they make things worse when the old IR remotes worked perfectly without this hassle ?? SO how do you ensure that COREelec reboots with the new naff remote fully paired and working?? SO far I have wasted nearly 3 hours on this and still unworkable??? It seems every change you get in life today makes things worse rather than better as used to be the case before this dystopian world we find ourselves in now !!

Sorry for the I feel understandable rant but I am so frustrated and peed off with this time wasting. I thank those who put up their remote configuration files into the store as that is much appreciated and indeed years ago put up my own nice and simple working remote.cfg file for an old box

A BT remote needs to be paired obviously. That’s the first part. Unfortunately, after that almost every different remote behaves differently, I have some that don’t need re-pairs in CE menu and others need it. It’s something it’s being worked on but no great breakthrough yet.

Thanks for the input but it is totally unworkable of course. At least I have no more need to spend a lot of time trying to find a cure. My friend cannot have to each time re pair his remote when he turns his CoreELEC Ugoos X4Q box on of course. Why do the box makers change form the good old reliable IR remotes ?? I will see if I can order a proper decent uGoos X4 IR remote and he can bin this BT one or keep it if eventually this will finally work practically. Anyway thanks again for your prompt reply, appreciated.

Feel free to help out to solve the issue:

It’s a bluez issue in general.

I didn’t check yet this Ugoos one but some BT remotes use IR when they’re not paired.

Edit: @RayW Here you have the file for that remote. You just have to be sure it isn’t in BT mode. I did this in mine by entering pairing mode and exiting it without pairing,

Hey Vasco thank you so much that has cured the problem totally. I did not realise this new X4Q remote was also IR although I knew the power button was IR of course which is essential. I restored the settings from my X4 Pro box and the different remote configuration of course did not work so assumed I needed the BT .hwdb file which I downloaded. So this standard remote.conf file works perfectly and all buttons function as they should.

Once again many thanks for your help, much appreciated.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.