❓ Which DTB do I use?

There is no dvb dtb. Mecool is no official supporter of CE.

Can I install such a program on my box?

Don’t post and ask for advice not related to this topic.
Go to the Youtuber link i deleted and ask there.

1 Like

I’ve downloaded the Odroid N2 version and following the install guide it says to copy the correct DTB from the Device Tree folder. The download already has a dtb.img file in the root.

  1. Do I still copy a fresh file over?
  2. If so do I use the dvb.dbt or just .dtb variation?

The imagem for the Odroid N2 already has the correct dtb. The dvb variations is only to use if you have an internal tuner like the Khadas vtv or the wetek tuner attached.

1 Like

Just reporting, for AZW (Beelink) W95 S905W 2GB RAM Box, use: gxl_p281_2g.dtb
Remote.conf file: NEW Repo for Remote files (Thanks to Betatester)

I’ve tried searching…
and haven’t been able to see other users of X96 Max Plus, with 2GB Ram and 16GB ROM, 100mbps LAN
The chipset is S905X3 …
Which dtb should i use ?
(using the generic version one for ce )


choose one based on the ram & lan size, if one doesn’t work try another

Device : X96 Max Plus RAM 2GB ROM: 16GB LAN : 100Mbps, NO Bluetooth.
Image : CoreELEC-Amlogic-ng.arm-
DTB : sm1_s905x3_2g.dtb
VFD & remote : just follow from this post below :

Hi All.
I just received a X96 Air i purchased.
I cant get it to boot up using the any of the s905X3 DTB images.
Get this error
*** Error in mount_storage: mount_common: Could not mount LABEL=COREELEC ***
However if i use a S905X2 DTB it does boot into CE, LAN works but no WIFI and it doesnt reboot without powering down the device.

It is definitely a X96 Air P2. 4GB Ram 32GB Storage.

You can check in Android AIDA application if you really have s905x3 or not
Or in CE upload the output of command:
cat /proc/cpuinfo | grep Serial
Also info about your SOC available in CE settings info

Definitely a S905X3.
4xARM Cortex A55 @ 1908Mhz

I Fixed the issue…
Turns out it was the SD card i was using (EMTEC gold) which was the culprit.
Used a Sandisk and it worked OK, Now using the EMTEC in my Mecool MS8+

I bought a X96 Max Plus
The site show me I have to use: sm1_s905x3_4g_1gbit.dtb
I copied the root, rename to dtb.img /stable version/
I ty all the methods, not only the reset first start, but no one works
It freeze on the X96 Max + logo when booting.
That means the dtb file is wrong.
Which one I have to use it?

try holding the reset button in for slightly longer or slightly shorter, as you plug in the power lead.

it is not about how I start it, the dtb.img not good
Here is the same problem, but no solution, this is why I asked.

Have you tried some of the other .dtb files such as 2g files?

Yes, and how they wrote on the link above
It have problems with that 2G file
Only 2Gb system memory can see the system, no 4k, and more…
It start with it, but working wrong

Hello, i´m using Formuler Z8… Can you help me to choose correct dtb file?

You have just provided the name of the device. The device tree is based on the LAN gigabit or 100mb PLUS the RAM size.
But CE is for amlogic devices

It seems this device uses Hisilicon Quad-core. So to me, you can’t use CE