❓ Which DTB do I use?


#1

As part of the CoreELEC install process you are required to copy a device tree from the device_trees folder on your sdcard/flash drive to the root folder of your sdcard/flash drive and rename it to dtb.img, failure to do so will result in either your box being unable to boot or network problems.

Every device is built differently and there is so many to choose from on the market, below you can find a list of some of these devices along with the corresponding DTB you must use.

If your device is not on the list then and you know which device tree is compatible then reply to this topic and help us keep the list updated.

Device              RAM/STORAGE          CPU          DTB

A95X A1             1G/8G                S905X        gxl_p212_1g
A95X-B7N            2G/8G                S905X        gxl_p212_2g
A95X-R2             1G/8G                S905W        gxl_p281_1g_a95xr2
A95X-R2             2G/16G               S905W        gxl_p281_2g_a95xr2
Abox A1 Max         1G/8G                S905W        gxl_p281_1g_a95xr2
Abox A1 Max         2G/16G               S905W        gxl_p281_2g_a95xr2
Akaso HM8           1G/8G                S905X        gxl_p212_1g
Beelink GT1 Ult.    3G/32G               S912         gxm_q200_3g
Beelink GT1 Ult.    3G/32G(fake RAM)     S912         gxm_q200_2g
Beelink Mini MX     2G/16G               S905         gxbb_p200_2G_1Gbit
Beelink Mini MXIII  2G/16G               S905         gxbb_p200_2G_1Gbit_RealtekWiFi / gxbb_p200_2G_1Gbit
Beelink Mini MXIII II 2G/16G             S905X        gxl_p212_2g    
Bqeel M9C Max       2G/16G               S905X        gxl_p212_2g
Bqeel M9C Pro       1G/8G                S905X        gxl_p212_1g
Edal T95Z Plus      2G/16G               S912         gxm_q200_2g
H96 Pro             2G/16G               S912         gxm_q200_2g
H96 Pro             3G/16G               S912         gxm_q200_3g
KIII                2G/16G               S905         gxbb_p200_2G_1Gbit
Mecool HM8          1G/8G                S905X        gxl_p212_1g
Mecool KII Pro      2G/16G               S905         gxbb_p200_2G_1Gbit
Mecool KIII Pro     3G/16G               S912         gxm_q200_k3_pro
Mecool KM8          2G/16G               S905X        gxl_p212_2g
Mecool KM8 P        1G/8G                S912         gxm_q201_1g
Mecool M8S Pro+     2G/16G               S905X        gxl_p212_2g
Mecool M8S Pro L    3G/32G               S912         gxm_q201_3g
Mini M8S II         1G/16G               S905X        gxl_p212_1g
Mini M8S II         2G/16G               S905X        gxl_p212_2g
Minix NEO U1        2G/16G               S905         gxbb_p200_2G_minix_neo_u1
Minix NEO U9-H      2G/16G               S912         gxm_q200_2g_minix_neo_u9
MXQ Pro 4K          1G/8G                S905X        gxl_p212_1g
Sunvell T95M        2G/8G                S905X        gxl_p212_2g
Sunvell T95N        2G/8G                S905X        gxl_p212_2g
Sunvell T95X        1G/8G                S905X        gxl_p212_1g
Tanix TX3 Mini      1G/8G                S905W        gxl_p281_1g
Tanix TX3 Mini      2G/16G               S905W        gxl_p281_2g  
Tanix TX3 Pro       1G/8G                S905X        gxl_p212_1g
Tanix TX3 Pro       2G/16G               S905X        gxl_p212_2g
Tanix TX92          3G/32G               S912         gxm_q200_3g
THL Box 1 Pro       2G/16G               S905X        gxl_p212_2g
Vontar TX92         3G/32G               S912         gxm_q200_3g
Vorke Z1            3G/32G               S912         gxm_q200_3g
Vorke Z6            3G/32G               S912         gxm_q200_3g
WeTek Play 2        2G/8G                S905         gxbb_p200_2G_wetek_play_2
X92                 3G/32G               S912         gxm_q200_3g / gxm_q201_3g_1gbit
X96                 1G/8G                S905X        gxl_p212_1g
X96                 2G/16G               S905X        gxl_p212_2g
X96                 2G/16G               S905W        gxl_p281_2g
X96 Mini            2G/16G               S905W        gxl_p281_2g
Xtreamer Whizz      2G/16G               S905H        gxbb_p200_2G_1Gbit
Z69                 3G/32G               S905X        gxl_p212_3g

How to install CoreELEC
Mecool KII PRO S905D
CoreELEC not booting - Nexbox A95X
A95X -R1 / S905W issue
MeCool KM8 P TV Box Amlogic S912 1GB fails to boot with CE 8.90.2
How to configure IR remote control
How to install CoreELEC
3GB RAM H96 Pro
Trees Beelink MiniMXIII II 2GB
Updating M8S PRO+ S905X or not - beginner questions
How to configure VFD
Wetek Play 2
S905X 1GB Generic - No DTB Working
S905X 1GB Generic - No DTB Working
Vorke Z5 / Tanix 3 Mini Dual OS update LE 8.92 to 8.95.1 has ended with an error
Beelink GT1 (no ultimate)
8.95.0 9082xs No Wifi
Wifi issue with latest build 8.95.3
Nightly builds
#11

I’d like to contribute to this list, but how do I find out which dtb is in use? (I tried a few before I finally found one which worked as my box has fake ram)


#14

SSH to your box and type cat /proc/device-tree/le-dt-id


#37

You need to use the DTB included with CE, DO NOT use the old DTB.
The instructions on how to get the vfd working are here, in the first post. I will later make a new post on CE forums to cover this topic.


#44

Thanks to;
@hdj, @kassak, @teeedubb, @TheCoolest, @Pelican, @trohn_javolta, @frequenzy, @Sholander, @astrithaxhiu, @Rascal, @tico, @librenoob, @no1home, @bubblegum57, @FckSny, @Julien_SGN, @Garcea, @CI6N0Z, @Habibie, @aphilgr1, @tosa, @derTyp, @guil70, @ygor.almeida, @Vertex, @DigiTo :clap::clap:
. . . for your info (Individual posts deleted once info added to table, to keep thread lean) :+1:


#47

@derTyp and @guil70, it’s easier and better for the moderators if you guys follow the same frame as adamg’s post. Here is an example where the text is marked as “preformatted text” from the toolbar.

Device              RAM/STORAGE          CPU          DTB
A95X A1             1G/8G                S905X        gxl_p212_1g

#58

In this post you find an extended list: https://www.kodinerds.net/index.php/Thread/62495-Welche-Device-Tree-DTB-IMG-ist-die-richtige-für-welche-Box/?postID=476160#post476160


#65

Device RAM/STORAGE CPU DTB
W95 1G/8G S905W gxl_p281_1g

Remote files


#66

Which one would i use for an Odroid C2?


#67

As far as i know, you don’t need any dtb for Odroid…just download the right version:
https://github.com/CoreELEC/CoreELEC/releases/download/8.95.2/CoreELEC-Odroid_C2.arm-8.95.2.img.gz


#68

What DTB to use for TX3 Max (Bluetooth)
Does it exists?


#69

I have a MXQ Pro 4K
I use gxxbb_p200:1G:100M and works fine with SD Card, but when a make installtointernal don’t boot to nand.
I try to make installtointernal 3 times

Anyone help me, please?

Best Regars

Update - I try one more time and now works :smile:


#70

I have what I believe is a nexbox A95x S905 (not the S905x) 1gb ram 8gb flash.
That is the is the android firmware I was able to load onto it anyway.
(I got it second hand so that is why I am not 100% of the original manufacture)

It is also labeled OTT TV Box A95X on the case, and A95XMini on the system board.

I tried the gxbb_p200_1G_1Gbit DTB, and got it too boot (I haven’t tested the wired NIC yet).

Thanks.


#71

No Gigabit Ethernet on that box.
Realtek wifi fix device tree needed if running wifi.
Uboot Fix Android rom also available for power on from standby.
It won’t power on with Le / Ce with crap Android supplied stock uboot.
gxbb_p200_1G_100M_RealtekWiFi.dtb


#72

Hi there,

I have one of the newer KI Plus boxes with the S905D chipset. I am using the gxl_p231_1g_dvb.dtb device tree an everything works fine except Wifi. From the kernel log it seems to get initialized somehow but there is no option to turn it on or off in CoreELEC.

Any thoughts?

Best regards and keep up the good work!


#73

A95X Pro
2G/16G
S905W
gxl_p281_2g_a95xr2

Everything works fine without any special configuration, including the RF remote and Logitech Harmony remote (configure as Nexbox A95X).


#74

Could you point me to the Uboot fix please?


#75

#76

That helped. Thanks.


#77

Every time i update CoreELEC, i got this message after rebooting :

“Filesystem corruption has been detected! prevent an automatic repair attempt continuing press any key or off your system within the 120 seconds”

I always have to do this trick while booting on sd image :

Login over SSH and execute dd if=/dev/zero of=/dev/dtb bs=256k count=1 then dd if=/flash/dtb.img of=/dev/dtb bs=256k

Is there a permanent fix for my Minix U9-H?

Thanks.