Why's my remote iffy?

What would cause a remote to work intermittently? I find I’m often having to keep clicking to get a response and other times it seems to work fine so what would cause this? Yes it’s a meson mapped remote for my T95Max+

Is this something I have to live with or is there a possible fix for this?

Are you sure the remote is unresponsive or maybe the GUI is lacking due to some other heavy background activities.

Yes it does seem to happen more often when stuff is going on in the background or when the temp is high. Isn’t there way to give the remote some kind of priority? I’ve never known a remote to be so iffy.

Perhaps when my library has sorted it’s head out, lots of pix downloading, things will improve but it does seem odd as I’ve never experienced this before.

What I am saying is that the GUI could be hanging. Hard to tell. Are you using meson-ir or amremote?
You could try switching and see how it works out.
You can also tweak repeat and delay foe button presses. If you need higher priority you could look into smp affinity. Although there already is a script that should do it by default.

If it’s temp issues I would get a better box ;).

1 Like

Yes using meson so how would I go about getting the amremote file/s? Is the the remote,conf that people used to pull from Android? If so how and where would I find it?

There is a Thread on the forum that is collecting remote confs inside of a repo. If there is none you can create one. There are several how to’s on this forum.

1 Like

OK will look into it, thanks.

Forgot to ask, where the best place to put remote.conf?

1 Like

I take it that as I already have the meson remote file I can convert it into a remote.conf file (amremote)?

Just wondering what this stuff at the top of a generic amremote file is all about?

mod by hungphutho kodiviet.com

factory_code = 0x40400001
work_mode = 1
repeat_enable = 1
release_delay = 150
debug_enable = 1
reg_control = 0xfbe40

OK reading a ‘how to’ and it’s a bit more complicated than at first thought, Will have to allocated an evening to this.

1 Like

Well I tried having a go at creating a remote.conf but it got too complex for me. Tried all the SSH and dmeg -c stuff, pressing remote keys and writing codes down but couldn’t get anything to work. Isn’t there a way I can grab the remote.conf from android? Think these boxes are rooted so not sure if I can get to the file.

For the record the remote works fine in Android but is still glitchy in CE using the meson remote files. Box isn’t doing anything so can’t understand what’s causing the drop outs in functionality.

Sorted with a work around:
I used the remote.conf from my NEXBOX A95X which has a similar remote and it worked. I had to tweak the repeat delay etc to get it working perfect. Now I can program the keys into my all in one remote and I’m all set.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice