Widevine DAZN Odroid N2

Hi, today I made a fresh clean install with the latest CoreElec19 on my Odroid N2. After installing the DAZN addon (via Kodinerd-Repo) and after widevine installation the playback within DAZN did not work. I remember having the same problem a year ago after an upgrade of my former installation. Back then I found the solution in some other forum. I had to replace the libwidevinecdm.so file within the /storage/.kodi/cdm/ folder with an alternative file. I even found the web site where the link to the alternative file was given. But the link is not working anymore.
Has anyone an idea of how to solve the problem or where to get this alternative libwidevinecdm.so file?
Thank you!!

Use InputStream Helper addon to modify, update, etc, libwidevinecdm.so

Thanks for your advice. Unfortunately it did not help. I have Version 0.5.2+matrix.1 of INpuSTream Helper installed. What I tried was to delete existing CDM library and reinstall it what did not solve the problem. Then I tried to restore it but was only one backup given. After restoring it the playback issue was still there. Wtihin InputStream helper I could not find any other tweak to try out.
What else could I try?

Maybe try this from within inputstream helper:

  1. Remove
  2. (Re)install

Latest version of widevine should be 4.10.1679.0, inputstream helper 0.5.0+matrix.1 and inputstream adaptive 2.6.14.1

Maybe also verify it works under Windows / Linux.

FYI we do not support unofficial 3rd party addons like DAZN. If it’s the app causing an issue you’ll have to contact the developer of the app.

Contact addon maintainer, because sometimes it happens that DRM protected streaming addons don’t work with latest Widevine and need an older version.
What is your present Widevine version, and if you know with which version it worked before? I have some older version in archive and maybe have one that you need.
But, Netflix, Amazon Prime, HBO-Go…, will not work then with any older version…

Thanks all of you. Its working now!! I am not sure why. It worked after I started the system anew last night. May be its due to the restart of the system that I may have forgotten after playing around with InputStream Helper. Or may be DAZN app was updated in the background.
Thanks again!!

About | FAQ | Terms of Service | Privacy Policy | Legal Notice