Wifi problem on Tanix TX3 Mini


I have just got myself a Tanix TX3 Mini and I have tried with both the stable and nightly, both boot without issues, however it cannot see any wifi, when looking at network after, it shows no device, I do not see the specified model in a search, so it may not be supported.

SD and terminal states it’s 9012p, found nothing with that on google, nothing with wll9086x and then mac80211, does return some results on here, but seems to be bunched with other things aswell and some models different to 9012p.

Any help would be appreciated, I won’t go the usb device root as not putting that much into something that’s for testing/learning and have different box on the way aswell.



WiFi is not supported on this device and never will be, no driver is available, it’s been this way for 3 years now.

ahh, ok as the posts i did see was to do with the fake chip that’s different number to mine, that’s pretty crappy that i’ve wasted money on it

hmm, I used my TX3 Mini with no problems at all with Wifi on both Coreelec and Emuelec

But that was the first generation mini, direct from Tanix

My hunch is there are a bunch of clones now using different chips.

Hello, I guess that I found a source (for 9012 aka 9086):

@dyorgio we successful compiled the driver.
But there is now the problem as the same I’d is used for 3 different types of this WLAN chip.

Do you have a device with this chip and can test the driver?

1 Like

Yes, I have a TX3 mini (s905w with 9012p)

There is a chip config exist for s9083, s9188 and richv300.
Any idea what will match with yours so I can prepare a test image?

Maybe you can make a dmesg log from Android?

Looking at sources I guess that is s9083 config (maybe it is a “work in progress” source…)

Theses lines:
ifeq ($(CONFIG_CHIP), s9083)
$(MODULE_NAME)-y += os/linux/pwr/power_rich100.o

CONFIG_RICHV100 directive needs to be true to include xxx9086 methods…

I don’t have dmesg available (using Emuelec), but I have this:

E: SDIO_ID=02E7:9086
E: MODALIAS=sdio:c07v02E7d9086

@dyorgio please try this image:

After install please make a dmesg | paste log, thank you.

@Portisch not sure if it is the correct file.
I expected a .img (to burn in SDCard).
If there is a command line to transform it to img, please tell me


@dyorgio does it work now?

Hi @Portisch, I already put last version of CoreElec on my device, but I don’t have a usb keyboard :joy: (neither remote control for it, it is “the brain” of my arcade machine).
I’m buying one on Amazon, and when it arrives I will test update via ssh.
I tried to make a way to enable ssh by default on CoreElec, but no luck :frowning:

I suggest looking into an MX3 Air Mouse.

1 Like

You don’t need a keyboard to update, just copy the tar in the update folder and reboot

After booting you can upload the log by Kodi:

Mac user here :slight_smile:, but I found a way to write on ext4 partition and get update done.
The problem stay on missing keyboard. I don’t have any input device to use Kodi and ssh is disabled.
It recognized my joypad, but opens a dialog to confirm configuration before it can be used (and again, I have no input device to confirm this message :joy:). I just buyed a low cost keyboard on amazon. Be patient please.
Until that, update appears to be applied ok, Is there any log than I could cat on SDCard to be analyzed?

To enable ssh by default you need to open file config.ini on first partition on sd card. At the end add this line and ssh should be enabled.

coreelec='quiet ssh'
1 Like

@vpeter you are the best! just works!

@Portisch dmseg: http://ix.io/3RGQ

and ifconfig/iw:

wlan0_s0  Link encap:Ethernet  HWaddr C8:2E:47:21:1F:2A  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:131867 (128.7 KiB)  TX bytes:0 (0.0 B)

CoreELEC:~ #  iw dev wlan0_s0 scan
command failed: No such device (-19)

Use “iw dev wlan0 scan”