Wifi problem on Tanix TX3 Mini

Yes, only the 9083 did load the firmware on the chip. But it’s crashing the system. So we can’t help further here without physical touch the hardware. Maybe you find another driver what is working.

I sent a mail to repo owner, lets see if it can pass the China’s internet wall :joy:.

@dyorgio please make a new log with this image:

Not sure if it is ok, I used base image: CoreELEC-Amlogic-ng.arm-19.5-Matrix_devel_20220308220529-s9083

and updated to: CoreELEC-Amlogic-ng.arm-19.5-Matrix_devel_20220310103916

This is a log of the old image. The new image should print something Thu Mar 10

An update error maybe? .update dir was cleaned. Could you provide a full img? turn all debug logs on :nerd_face:

Do not try to update from another test image, please use 19.4 stable or nightly image.
When you try to update from one of the test images it will not work as the eMMC driver is crashed and you can’t save the update on the device.

So try again with this image:

Or you can use this img.gz for a clean install:

I can now list networks with:

CoreELEC:~ # iw dev wlan0_s0 scan | grep SID
	SSID: Nascimento
	SSID: Dyorgio
	SSID: Michele-2G
	SSID: Carol

But it can’t connect, this log is from wpa_supplicant (I tried two diff networks that I have here (sid/pass)):

OK, I can connect, it was another wpa_supplicant process in background.
But no ipv4 (I disabled ipv6 to test, also no ipv4).

Good news :smiley:
I restart and found a tutorial do use connman.
Wifi connected and few seconds later get a ipv4.

I can’t test it using curl --interface wlan0_s0 google.com

So, I disconnected eth cable and tried to connect ssh using wifi ip.

And it works!!!

then I made curl test again and works too…

But… few seconds later, it just stop, and I can’t connect on wifi ip.

I put eth cable again, no way. just restarting…

The driver still crash the system and I think it can not be solved…

I have an early TX3 Mini too (though with 9082C WiFi but I only use the Ethernet port) and it runs 9.2.8 fine. Like @dyorgio, I too believed that it wouldn’t run NG and that the box would need to be retired but this gives me hope.

Is there a particular NG image that I should try? And can I do an update by putting the tar file in the Update folder and rebooting or do I need to do a clean install of some sort?


The device itself is supported by CE-19 Matrix but no Wifi right now. We going to debug it more to get this Wifi chip running. So when you use LAN only you are able to use the device as normal.

I flashed 19.4 to a new USB drive, copied gxl_sm281_1g into the root folder, renamed it to dtb.img, booted the Tanix TX3 Mini with a toothpick holding down the reset button, the 1080P LG TV showed resizing of the flash drive, rebooted into CE. I did the initial setup. I paired a Amazon Fire TV Bluetooth remote and confirmed it is working fine. I installed the OpenVFD Add-On and copied tanix-tx3-vfd.conf file from github into the Samba mounted Configfiles folder and renamed it to vfd.conf. I then rebooted into CE and got a blank TV screen. I can SSH into it successfully and reboot it into the same state i.e. nothing displayed on the TV but time etc showing on the VFD.

If I take out the USB drive, the box boots up into Android fine.

Output of dmesg is at http://ix.io/3SzU

# cat /sys/class/amhdmitx/amhdmitx0/disp_cap

P.S.: I have 2GB of DRAM but the download helper said to use the 1GB DTB file.

I stumbled upon a workaround which is to switch the TV input to some other source and then back to the Tanix to revive the display!

I’ve since noticed that there are times when the unit becomes non-responsive to the GUI for several minutes and then is fine again. During that time, I can’t even SSH into the box.

Could it be swapping since I’ve used the 1G DTB file? How hard is it to switch to the 2GB DTB file?

Simply switch gxl_sm281_1g with gxl_sm281_2g on the USB Drive.

It’s a drop down menu. Not everyone notices right away. I’ll see if we can do something about that.

I’m usually good about noticing these things!


Support for Smartchip WiFi got added with 20220323 nightly.
All 3 modules are included in system now:


The driver is default Disabled and if the SDIO VID:PID 02E7:9086 is found it’s possible to choose the correct driver matching with the Smartchip assembled in CoreELEC-Settings hardware tab.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.