WIFI tethering doesn't work on Mecool KI Pro

I tried to activate WIFI tehering on Mecool KI Pro. I can connect to it from my PC but I think that the PC don’t get the right IP address. Therefore the access to internal network and also to the internet isn’t possible. Is there any possibility to get WIFI tethering working?
Moreover KI Pro supports 2.4/5 GHz WIFI networks. But it is not possible to choose the frequency for WIFI tethering.

Do you get an ip address? I suggest to disable iptables firewall then reboot after that try to enable tethering.

The notebook is connected but don’t get an ip address.

CoreELEC:~ # ip route list
default via dev eth0 dev tether scope link src dev eth0 scope link src dev eth0 scope link

Is a DHCP server missing for the tether interface?

Have you tried to set firewall to off?
Dhcp and dns is included.

I don’t see any rules with iptables --list. Is there any specific command to set firewall to off?

In GUI. CE settings under Network

Firewall was already deactivated in CE settings.

1 Like

Yes, after execution of “ip link set dev wlan0 master tether” thethering works. Thanks.