Wiki/Doc to build CoreELEC?


#1

Can anyone please provide a Wiki and/or document on how to build CoreELEC? I already pulled a copy of CoreELEC and when I ran make, it spitted out messages as shown below. Then, I executed make S912 and it spitted out an error message as shown below, too. Is there such a thing like make menuconfig so one can configure the source before building CoreELEC?

[habibie@linux:/mnt/devel/CoreELEC_git 345%] ~ make 
./scripts/image release

 =================================================================================
 ERROR: You need to specify a valid device for the Amlogic project
 =================================================================================

 Valid devices for project: Amlogic
 - KVIM
 - KVIM2
 - LePotato
 - Odroid_C2
 - S905
 - S912
Makefile:9: recipe for target 'release' failed
make: *** [release] Error 1
[habibie@linux:/mnt/devel/CoreELEC_git 346%] ~ make S912
make: *** No rule to make target 'S912'.  Stop.
[habibie@linux:/mnt/devel/CoreELEC_git 347%] ~

#2

DEVICE=S912 make image
This instruction can be used with little changes somewhere
Compile


#3

This is what I get when executing the above instruction.

[habibie@linux:/mnt/devel/CoreELEC_git 361%] ~ DEVICE=S912 make image
DEVICE=S912: Command not found.
[habibie@linux:/mnt/devel/CoreELEC_git 362%] ~

#4

Follow the instruction to install all required packages to step “Start compiling”
After you can use this command


#5

Can you please provide the link for such instruction?


#6

Link is in my first reply
image


#7

Got it. Thank you. However, I am still facing the same issue even after installed all the required packages. That said, it looks like the error message of DEVICE=S912: Command not found. has nothing to do with the fulfillment of software requirement.

[habibie@linux:/mnt/devel/CoreELEC_git 386%] ~ DEVICE=S912 make image
DEVICE=S912: Command not found.
[habibie@linux:/mnt/devel/CoreELEC_git 387%] ~

#8

The commands for you:
"
PROJECT=Amlogic DEVICE=S912 ARCH=arm tools/download-tool

PROJECT=Amlogic DEVICE=S912 ARCH=arm make image
"


#9

What os do you use ?


#10

I have several Linux desktop computers running different Linux distros, i.e. debian, OpenSuSE, and Ubuntu. They all share the same CoreELEC source hosted on my NAS using NFSv4. I tried on all of them and ended up with the same issue.

[habibie@linux:/mnt/devel/CoreELEC_git 372%] ~ PROJECT=Amlogic DEVICE=S912 ARCH=arm tools/download-tool
PROJECT=Amlogic: Command not found.
[habibie@linux:/mnt/devel/CoreELEC_git 373%] ~ PROJECT=Amlogic DEVICE=S912 ARCH=arm make image
PROJECT=Amlogic: Command not found.
[habibie@linux:/mnt/devel/CoreELEC_git 374%] ~

#11

I got the compile on the basis of the description.


#12

I’m not a linux expert. But Ubuntu definitely works, at least as long as it’s on the local file system.


#13

Looks like something is missed due to network location.
Did you run all commands on local(where you compile) PC? I mean git clone and etc?


#14

Found out the cause: my account defaults to tcsh (not bash). Thank you everyone.


#15

I was just going to ask which shell prompt you was using as ubuntu defaults to dash and must be changed for similar reasons but it appears you have it resolved.

On a side note, compiling over NFS will be extremely slow as thousands of files are touched.


#16

You are right. Currently, I can obly get about 60/35 MBps R/W through my NFS NAS. Do you and/or anyone else here know if samba will give a better R/W throughput?


#17

No, Samba will give even worse results, I would only build over a network with a Fibre connected SAN as you will probably be waiting a considerable amount of time for a build to complete otherwise.

Most if not all of the CE team use a SATA connected SSD at a minimum as even using a local HDD can increase build times considerably.


#18

That’s true. I am sure you all do this on a very fast multi-core computer with lots of RAM with very fast SATA and/or SSD storage. Unfortunately, I am on a limited budget and have to be content with some old AMD64 Phenom II X3 computers with only 4 GB RAM to share a NAS. BTW, if I may ask, how long does it take to averagely compile on your computer to produce a CE firmware?


#19

A fast PC is great, but building is mostly an IO type of thing, and a fast drive is critical. I wouldn’t be surprised if a full build will take around 5-10 hours via NAS.


#20

Clean build for me takes about 75 min. with i7 4790k and SATA SSD. That’s with most source files already downloaded from previous builds.