Working USB Wifi/Ethernet adapters for CoreELEC


#21

I took a punt on this USB gigabit NIC, plugged it in and it worked straight out the box. Played a 100mbit 4K test file and my server reported over 300mbps traffic during the initial playback, then dropped down to 100mbps, no stuttering.


#22

From dmesg output, can you find out what USB3/NET chipset device uses?


#23

It’s a realtek 8153


#24

That is good to know, especially for those who wanna buy a USB3/NET dongle. Thank you.

FYI, I ONLY have several USB2/NET dongles, i.e. a Davicom DM96xx USB 10/100 Ethernet (dm901) and ASIX AX88772B USB 2.0 Ethernet (AX88772B). The former (with a dm901 USB2/NET chipset) can only deliver an up/down-load throughput of no more than 2/4 MBps while the later (with an AX88772B chipset) can deliver 8/10 MBps, respectively. I use the later on my Rp0 which is configured as a server for non-media application. So, I have no way to test it to watch any video stream, let a lone a 4K video stream.


#25

I have bought USB3 dongles with ASIX AX88179 and Realtek RTL8153 chipsets. Both work right out of the box on Coreelec/Libreelec/OSMC etc. with no requirement to install any drivers.
I found i was getting better and more consisstent performance form the Realtek dongle when connected to a USB 2 port.
On there internet there are may who recomend the AX88179 dongles due to compatibltiy with nintendo switch etc. If you have a choice, I would recomend the Realtek for Linux based applications.


#26

Yes and realtek completely supports Linux.


#27

Just to let you all know…i tried several usb wifi adapters …the asus ac 68 and alfa network awus 1900 ac…they have the 8814 au wifi chip that did not work…than the edimac utb 1200 with the 8812 au wifi chip that did not work…but after stumbling on the 8812 au with the right dev and vendor id, the alfa awus036ac…it worked right out of the box…it has mimo and other stuff and performs excelent with two extnal antennes on 843 mbs…so look for the right dev id on the 8812au chip on wikidev…


#28

Thanks Paauw for info regarding 8812au support for awus036ac.
I would be interested into some cheaper alternatives with 8812au chipset working in CE.
Looking at ebay there are some, anyone tested these in CE?:




#29

TP-Link TL-WN725N v3 wifi adapter ( Realtek RTL 8188EU chip) working on Coreelec? Driver for Linux: https://static.tp-link.com/2018/201805/20180521/TP-Link_Driver_Linux_series7_beta.zip Thanks for help and sorry for my english :wink:

https://www.tp-link.com/pl/products/details/TL-WN725N.html


#30

CoreELEC already has a driver for the RTL 8188EU chip built in.


#31

Thank you @TheCoolest.


#32

Can someone recommend an USB Wifi plug that is supported by CE and uses 5Ghz wifi with maximum speed?


#33

I have this one https://www.amazon.de/gp/product/B07B498WMB/ref=oh_aui_search_detailpage?ie=UTF8&psc=1 which works great


#34

Great, I will try that, thanks!


#35

I am using an AC1200 USB D-Link dwa-182.
edit
I am taking back my recommendation for the D-link. I am not sure if I have a bad unit, but I started getting random system freezes when pushing a lot of network data.

I switched to a tp-link t4u AC1200 usb nic, and so far it has been flawless.


#36

https://www.aliexpress.com/item/Ugreen-USB-Ethernet-10-100-1000-Mbps-Rj45-Gigabit-Network-Card-Lan-Adapter-3-Port-USB/32401431234.html?spm=a2g0s.9042311.0.0.27424c4d5lTAA1

Workin great.

Only ethernet :frowning:


#37

For Ethernet I use this: https://www.ebay.com/itm/112541143662


#38

Can you please test its performance using iperf3 to see how much reall throughputs this dongle can pump out.


#39

I would also like to see how much throughput this dongle can pump out.


#40

300-320Mbps down and ~180Mbps up.