X2 cube. USB Ports do not work

Device: X2 cube (Amlogic S905X2/ARM G31 MP2 GPU/2GB LPDDR4/16GB EMMC)
On CoreELEC-Amlogic-ng.arm-9.2.0-Generic.img.gz everything works as it should, except USB Ports. They do not work any device (keyboard, mouse, flash …).
On CoreELEC-Amlogic-ng.arm-9.2-nightly_20191101-Generic.img.gz USB ports also do not work.
On Android 9.0 and LibreElec USB ports work, but there are other problems.

1 Like

As solution you can try to start CE from usb stick.
The problem with USB occurs on some devices which start CE from sd card.

No boot from USB. 2 ports and 3 different drives were used.

Check a message I sent you in PM.
I know user with working ports on cube…
You can try to update Android to latest version and check if you still have an issue or not.

The solution for Ugoos boxes is to add this 4 lines in autostart.sh files and you can again boot from sd card with working USB’s

echo 432 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio432/direction
echo 1 >  /sys/class/gpio/gpio432/value
echo 432 > /sys/class/gpio/unexport

I am very ashamed, but I cannot see the autostart.sh file. Created a file with this name in the root of the sd card. At boot, the ports still do not work. It will not boot from a USB flash drive. Tried on CoreELEC-Amlogic-ng.arm-9.2-nightly_20210120-Generic and CoreELEC-Amlogic-ng.arm-9.2.5-Generic. Thank you in advance.

Wrong location
You have to create autostart.sh in /storage/.config

I do this …
I write the CoreELEC-Amlogic-ng.arm-9.2.5-Generic.img image to the sd card. I transfer the file g12a_s905x2_4g_1gbit.dtb to the root of the map and rename it to dtb.img. I create a “storage” folder, create a “.config” folder in it and create an autostart.sh file there. I open it with notepad and enter the lines
echo 432> / sys / class / gpio / export
echo out> / sys / class / gpio / gpio432 / direction
echo 1> / sys / class / gpio / gpio432 / value
echo 432> / sys / class / gpio / unexport
I keep it. Then I boot from this card. And USB doesn’t work.

You don’t need to make this folder.
You just need to install CoreELEC and after this folder will be available via network as Configfiles folder or via ssh as /storage/.config

Sorry to be stupid. I connected to the set-top box over the network. I see the Configfiles folder. Do I need to create an autostart.sh file in this folder?

yes, you need to create autostart.sh file with this 4 lines, save it and reboot

Unfortunately the mouse and remote don’t work as before.

I forgot about 1st line in file
just copy this file and reboot
autostart.sh (164 Bytes)
if still doesn’t work please try to execute this 4 commands via ssh

1 Like

Great !!! It works. Thank you very much!))))