X96 Max 2G / 16G 100Mb/s using Nightly images

It appears I might have some weird version of this device as I see no other posts reporting my experience with it. :frowning: Else no one else has the device :slight_smile:

remote ok
wake from remote ok
wired nic ok
wireless nic no APs listed so nothing to connect to (8189es on Android and loaded on CE)
display no lit segments (or icons) at all

Both wifi and display work in Android

dmesg output

Just wondering if there is anyone else with a box behaving in this manner?

Have you tried the wifi without lan connected?

Yes, tried deactivating the wired NIC and also disconnecting the ethernet cable.
No difference.

I do notice that sometimes it will take a second reboot to even get the wireless NIC to show in CoreELEC Configuration Network settings.

nightly 0821

no wireless NIC seen at all today.
This happens with some of the nightlies … sometimes the wireless NIC is listed and other times not.

It did not show today even after a reboot which often forces it to show.
The wifi module was not loaded!
Loading it brought the listing of the NIC back, but seemed to make no other difference.

What is the wifi_dummy module used for?
It seems to be constantly loaded

Nightly 20190824

No display - not even one segment.
No wireless on first boot; it appears after reboot as Active Network
No entry under Connections … no APs etc.

Unfortunately I seem to have a one-off device which I accept now is unlikely to ever work correctly when using CE.
It seems no one else here has a similar problematic device.

It would appear that I am alone with the X96 Max 2GB board.

Oh well it will do as is, as there is no reason to put effort into trying to improve the situation.

This thread can be closed I guess.