X96 max 4K resolution not showing

Hi Core Elec Team,

I have the latest nightly build installed.
The setup:
x96 max > tx-nr646 > samsung 4k tv

Played 4k video but TV shows 1920x1080p 24hz only

checked the display settings in kodi and it only shows up to 1080 resolution.

AVR setup, hdmi passthrough set to on.

You need to make sure that UHD/Deep Color/HDMI 2.0 is enabled on both the TV and your AVR.

No such settings like that on both TV and AVR. Or i might be looking at the wrong settings. Can someone guide me on that?

You need to RTFM of both your TV and especially your AVR on how to setup and configure them for HDMI 2.0 and 4K HDR.
Make sure that you don’t have a disp_cap file in /storage/.config.
You may also need a good HDMI cable, but this should not prevent listing 4K resolutions.

As a test connect the box directly to the TV and see if 4K resolutions are listed and that 60hz option is there for 4K.

Hi TheCoolest,

HDMI is fine, it is working for other sources, HDCP 2.2 is also setup properly on AVR.
Will test connecting it directly to TV as I haven’t done that yet.
I’ll also check disp_cap and see if it is on the /storage/.config

That means you have a configuration issue. Probably in the AVR, or you’re connected to a HDMI port on the TV that doesn’t support HDMI 2.0.
I’m not talking about HDCP 2.2, but HDMI 2.0.

Try connecting the box directly to the TV, and make sure that you connect it to a HDMI 2.0 capable port.

The HDMI port that I was using on my TV was the incorrect one hence the limited resolution.
Thanks again! And by the way, I also edited the guisettings.xml by removing all the resolutions stuff because it messed up my 4k video playback by cutting the video in half. It has been fixed as well after the edit. thanks again guys!

1 Like

Which .dtb are you using with the nightly on the X96Max?