X96 Max and CEC error

I just bought a X96 Max 4GB/32GB/1Gbit and everytime CoreELEC start I get a popup to show a CEC error.
What kind of log I can provide to help you to solve it ?
Thank you !

SSH and type “dmesg|paste” and paste the link here.

Thank you, the link is http://ix.io/1VGq

I have the same box (X96 Max S905X2 4G/32G/1gbit) and I have two Toshiba 4k TVs. One is model number 43U5863DB and the other is slightly newer model 43U6863DB. With the newer model, CEC works perfectly - every time - with the older model, it works maybe 1 in 20 (and even then only if TV is switched on).

With the newer model, it doesn’t matter if TV is on or in standby etc - it just works. This is using the same box running CE v9.2.0.

I also have a S905X running CE v9.2.0 and a Rockchip RK3328 running LibreELEC 9.x. With both of these boxes, CEC works perfectly with either TV.

I have TVs directly connected to the box via HDMI.

Just thought I’d share this info.

Further update:-

I have now got the S905x2 box (X96 Max) working on both TVs. I upgraded the version of Android on the S905x2 box from Oreo to Pie (link - https://chinagadgetsreviews.com/download-android-pie-9-firmware-for-x96-max-tv-box-3.html). I used the SD card method to upgrade Android.

I activated HDMI-CEC in Android and then inserted the microSD with CoreELEC installed and ran CE v9.2.0. So far, CEC on the S905x2 box is working 100% with either TV (and I’ve tried a few times with each TV). I don’t know what ‘fixed’ the issue…

I’ve never had CEC issues before with any previous Amlogic or Rockchip boxes - they just worked with all versions of CoreELEC and/or LibreELEC in the past.

Hope this helps a little.

It’s an “issue” existing long time now; some boxes need that CEC is first enabled in Android and after that it works in CE. Read about this many times before…