X96 Max+ and continuous reboots on both Android and CoreELEC

Hello:

I have a problem with the TV-Box.

Data:

  • It is an X96 Max+ (S905X3), 4/64.

  • It has a “dual” system with Slimbox on the eMMC and CoreELEC 20.2 on a microSD.

  • The problem is that the device turns off (I correct: it reboots), normally a few seconds after turning on (although sometimes it “holds” for 4 or 5 minutes and then turns off and reboot); It ALWAYS reboot “spontaneously”. AND THIS HAPPENS BOTH WITH SLIMBOX (eMMC) AND WITH COREELEC (microSD). So it seems like a hardware problem, a priori.

  • I have tried putting 3 different power supplies (plugs; 2 5V-2A; one 5V-3A) into the device. With all of them it restarts only after a few seconds/minutes**. It does NOT look like a power supply problem.**

  • When it reboots a “curious” thing happens. On both Slimbox and CoreELEC, the device’s blue front LED, which displays the time, CONTINUES SHOWING THE HOUR during the reset time (on both systems). It is after starting to reboot that it goes from setting the time to putting boot / CE 20 on the LED. It does NOT seem that the power supply is interrupted at any time… unless the LED stays “on” without electricity for a few seconds (I don’t know if this is possible).
    - It is NOT a problem of overheating of the device. Normally when it turns off it is less than 60ºC (in CoreELEC I sometimes have time to monitor the temperature before it turns off).
    - It is not a problem with some external “peripheral” either, since I have tried disconnecting the little that is connected via USB, and it keeps restarting anyway.

  • When it comes to “loading” the “operating system” (be it Android or CoreELEC), because it often doesn’t even get there, normally the reboot happens when opening something (putting on a channel, opening an application), or while it seems that will “buffer” a video. That invites me to think that it could be a RAM memory problem (one of the modules that has a corrupt part, something like that), but it could be my feeling without any basis.

  • I have opened the device, but I have NO idea about hardware (but nothing at all; I am quite reluctant to do “DIY”). Apparently, I don’t see anything loose or anything “weird”, and the appearance inside is not at all horrible (it’s clean, there’s no dust, etc.).

  • On one of the times (the -NOT- reboots) it let me start CoreELEC, I managed to install the entware memtester application:
    https://bin.entware.net/aarch64-k3.10/me...4-3.10.ipk

Well: with the device with CoreELEC “stable”, I did the test 3 times (command in terminal via ssh):
memtester 1000 5

(test 1000 MB of RAM, 5 times)

And all 3 times, shortly after starting the test (come on, between 1 and 10 seconds after starting it) → restart.

So I’m pretty sure it’s a RAM problem.

If it is a RAM problem as I suspect… any advice about it?

Thanks in advance and kind regards

Before doing a theoretically master in analysis it is might be easier to open the case and attach a UART adapter?

This will tell you immediately what can cause such behavior. Just add nopkmute in config.ini as coreelec parameter.

Sure that I should know that, but… what is a UART adapter and how to use it?

Just add nopkmute in config.ini as coreelec parameter.

What is the use of:
nopkmute
command?

Kind regars

Looks to me as a HW defect - either DRAM (as you suspected) or one of the internal powersupply rails (5V is only the primary input, internal rails are 3V3 / 1V8 /1V1 / 0V8 / Vcpu)
If you have the capabilities to analyze & repair, just go on finding the rootcause.
If not, consider this as bricked HW to be replaced.

Disable CeC settings in Slimboxtv
And also on CoreELEC SD card.

See if issue is solved.

Maybe downgrade to older version Slimboxtv

Also
Yes is pain in the a@$
Remove SD CoreELEC
Remove Slimboxtv

Flash Factory Firmware
See results

Also Factory reset of current Slimboxtv may clear issue

This issue has been reported on multiple Forums
For X96 Max + Box