X96 Max+ (S905X3), install to internal with 9.2.8, NOT with 19.5 rc2

Hello:

OK, OK, I know that generic devices have NO support for eMMC install, but… por people who wants to do that, I’ll tell you my case.

I have a X96 Max+ (S905X3), and I tried to install to internal from SD with 19.5 rc2.

ERROR:


ceemmc -x

Starting CoreELEC eMMC installation tool…

System is not supported: sm1_s905x3_4g_1gbit!

There is NO official support by Team CoreELEC
if you continue to run this tool!
Continue? [y]: y

eMMC size: 0x000ed2000000 [64GB]

No CoreELEC installation found on eMMC

Install in dual boot mode, CoreELEC and Android on eMMC
Use CoreELEC data from
[1] current used SD or USB device
[2] existing backup on current used SD or USB device

Install in single boot mode, only CoreELEC on eMMC
Use CoreELEC data from
[3] current used SD or USB device
[4] existing backup on current used SD or USB device

Please choose one option? [1/2/3/4]: 3

Free space of ‘partition CE_FLASH’: 512MB
Warning: Could not find ‘dto’ partition!
Free space of ‘partition CE_STORAGE’: 60092MB

Used space of ‘/flash’: 235MB
Used space of ‘/storage’: 5MB

There is enough free space on eMMC for installation!

Install CoreELEC on eMMC.
Continue? [y]: y

Moved ‘env’ from offset 0x00004d400000, size 0x000000800000 to offset 0x000000400000
Moved ‘misc’ from offset 0x000051400000, size 0x000000800000 to offset 0x000000c00000
Moved ‘logo’ from offset 0x00004e400000, size 0x000000800000 to offset 0x000001400000
Moved ‘dtbo’ from offset 0x000052400000, size 0x000000800000 to offset 0x000001c00000

Starting to format the new ‘CE_STORAGE’ partition…
mke2fs 1.45.7 (28-Jan-2021)
Discarding device blocks: done
Creating filesystem with 15383552 4k blocks and 3850240 inodes
Filesystem UUID: 476890d8-3b88-4ec7-8905-6b3031a1acc5
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424

Allocating group tables: done
Writing inode tables: done
Creating journal (65536 blocks): done
Writing superblocks and filesystem accounting information: done

Error opening file for writing ‘/dev/reserved’!
Failed to write the new partition table to eMMC!


After this, I could NOT start from Android, but I was lucky, and booting from SD with CE was still possible.

So, other user (J.L90, Telegram) recommended me to try ceemmc -x from 9.2.8.

I made a 9.2.8 fresh install with other SD:
https://github.com/CoreELEC/CoreELEC/releases/download/9.2.8/CoreELEC-Amlogic-ng.arm-9.2.8-Generic.img.gz

and tried again:
**ceemmc -x **
from 9.2.8

It worked.

After that, with CE in eMMC, 9.2.8 upgraded to 19.5 rc2, restored backup, etc.


By the way, if you want to backup your entware stuff (.opt):
a) Bakcup it from ssh:
tar cvf /storage/backup/backup-entware-$(date +%Y%m%d%H%M%S).tar /storage/.opt

In /storage/backup you will have a file with a name like: backup-entware-20220909221737.tar

  1. Restore this backup entware (.opt):
    cd /
    tar xpf /storage/backup/backup-entware-20220909221737.tar

(the name of your file will be different, of course).

And all your entware (.opt) settings will be restored.

Perpahs could be a good idea to include .opt with CoreELEC backup by default… or give the option to the user.

Kind regards

I fixed it by installing version 19.3 instead of 9.2.8. At least that has a kodi 19 base. Then used ceemmc -x, and then i upgraded to 19.5 rc2.

Looks like ceemmc were broken lately. But good news: It should be fixed again in today’s nightly.