X96 Max+ Which version of coreelec works on it? and where is the ceemmc tool?

I’ve just purchased an x96 Max+ (should get it later today) and was wondering if the latest 20.2 build will work on it?

I was also thinking of installing it to internal memory but cannot find a download link for the ceemmc tool.
How does dual boot work? Does it ask which os to boot to every time or does it boot to last used os and have a plugin installed to switch to the other os?

I’ve downloaded the Stock x96 Max+ firmware and Amlogic burning tool in case anything goes wrong so I can restore.


“(…)and was wondering if the latest 20.2 build will work on it?(…)”

I’m using it (same device, bought 2 years ago in my case):

“(…)I was also thinking of installing it to internal memory but cannot find a download link for the ceemmc tool.(…)”

Follow this:

ssh, and:
ceemmc -x

Then, you will have to choose between some options… but you should test CoreELEC using micro-SD before.

Well I got the device and it couldn’t see my hard drives.
They were in MBR, after deleting volume and recreating as GPT it sees them fine.
Then I tried booting to coreelec off sdcard.
I wrote the coreelec image to sd card using win32 diskimager and used the toothpick method but coreelec never appears and it just hangs on x96 logo.
Also tried LibreELEC.USB-SD.Creator.Win32 with same result.
Also tried on a usb stick plugged into the usb3 and usb2 port.

I have 4G Ram version with Gb ethernet so I’ve copied over sm1_s905x3_4g_1gbit device tree and renamed it dtb.img

Current android version is X96Max_Plus_100W_20221019-1654

Any idea what could be the problem?

I finally got it installed, had to use sm1_s905x3_4g even though the x96 I bought said it has 1GB ethernet. Also installed to internal in dual boot mode after testing on sdcard.

Was ready to send it back to amazon yesterday, glad I tried a different device file :slight_smile:

I try exactly the same. Did you get the Coreelec emmc install working without problems?

Yes it’s been working fine, I don’t use ethernet though so not sure if that is working ok.
You have to copy a remote file over so the remote works properly (link to them is in the guide above)

That`s great news. I hope i get mine flashed to emmc too in a few days without problems. I need the ethernet. I read already how to configure the remote, but i hope it will work with hdmi-cec, so i can use my tv remote like i am using with my Raspberry pi yet.

Can confirm that HDMI-CEC is working fine on my LG CX & A2

Perfect :+1:

I got my MicroSD card today and hopefully i can test Coreelec from SDcard tomorrow before installing to emmc. Guess then i can just use my remote config from my rpi kodi to get hdmi-cec working.

No config is needed for CE & CEC, it just works.
You only need a config for IR or BT remote.

Wow that is awesome Portisch. You and the CoreELEC Team did an awesome job. Basic hdmi-cec really worked out of the box. I added already my custom config in ~/.kodi/userdata/keymaps/tv-remote.xml

I have also an old kodi log with all the key numbers that work on my tv-hdmi-cec-remote and this keys must be added to my CoreELEC config for my tv-hdmi-cec-remote i guess. Do you know where i can find the keymap file used for my tv-hdmi-cec-remote?

You don’t need to add any key, it just works.
Maybe not all keys are supported by CEC then you need to work around by adding a IR config and map these not supported keys.

My tv-hdmi-cec-remote support more then just the basic button via cec. I used that tv remote with an RPI before and i want to add these additional special keys like before with the RPI.

I think you are right all my tv remote CEC keys work, but they are mapped different. It looks like CoreELEC is ignoring my custom mapping i added here: ~/.kodi/userdata/keymaps/tv-remote.xml

I read about the ceemmc tool and it offers single and dual boot install.

Is there any advantage to use single install except the more free space i have on the emmc partition then? I don`t need the Android, but i also don’t need the 6GB additional free space Android consumes.

Is it smart to install in Dual Mode then or is that causing more trouble at the end?

When the ceemmc install happens does it copy my configured CE from SD-Card to the emmc or does it just install without my config from SD-Card?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.