X96 Mini (S905W) - HDMI problem on boot

Hi :slight_smile:

I’ve installed CoreELEC 9.2.1 on X96 Mini and unfortunately I’m experiencing a strange problem when booting.

If I boot the TV box with HDMI cable attached, when the CoreELEC bootscreen/splashscreen disappers, the HDMI signal disappears as well. I’m getting a “No signal” message.

If I boot the TV box with HDMI cable detached and I attach it later on, everything works just fine (in 1080p60 resolution) but it’s not feasible to keep pulling the cable out and putting it in every time I switch the box on.

I’ve tried on 2 different TVs and on a computer screen and the result is always the same. There’s no such problem when booting into Android 9 that’s on internal memory.

Here is displayinfo output when booting with HDMI attached and screen not working: http://ix.io/27g4

Here is displayinfo output when booting with HDMI not attached, inserted later on and with screen working: http://ix.io/27g2

I hope you can help me with this problem.

Best regards,
Crocodil

Same issue here, welcome to the club.

@Erario: You haven’t found any solution? Are you using the box at all?

Can you please copy the attached disp_cap file into root directory of Userdata folder and see what happens.

disp_cap (37 Bytes)

@kostaman: Hi :slight_smile: Unfortunately the disp_cap file didn’t change anything - the problem is still there. Later today I can provide the displayinfo output if that helps.

It has the attention of the Developers.
It is currently being tested with new development Kernel to see if it can be fixed rather than testing with current Kernel.
Hang tight and hope it can be fixed.

@kostaman If you mean the work done by @cdu13a, then I have already tested that it fixes the HDMI problem :slight_smile: I will also do some more general testing :slight_smile:

Thank you very much guys for all your great work! :slight_smile:

@kostaman the only difference with disp_cap is that I can see the logo of my tvbox at boot and also on reboot, but in no case can I see the CoreELEC splashscreen, “mode not supported” and not “not signal”.
I also tried with very low resolutions like 720p50hz, same issue.

Hi @Crocodil.

How did you solve the problem? The same thing happens to me and I can’t find a solution.

Thank you.

Greetings

@vtrapiella: Hi :slight_smile:

The problem is fixed only in the non-public version of of amlogic-ng nightly / dev build that @cdu13a has sent me. The plan is to eventually include the changes in official nightly and later in future stable release.

Regards,
Crocodil

I have the exact same problem
X96 mini 1g
When I boot with HDMI cable plugged I have NO SIGNAL after the boot logo
When I boot without HDMI cable plugged and I plugged after it works perfecty
Any news or modification to do from the non public nighly build ?
thanks

Can you try this build?
https://discourse.coreelec.org/t/coreelec-amlogic-ng-4-9-kernel-for-s905x-s905d-s905w-funhouse-builds/

About | FAQ | Terms of Service | Privacy Policy | Legal Notice