X96 X4 - S905X4 based box - any success?

Yes - today’s nightly with the non-Gigabit dtb is now booting to CoreElec. I’ve opened a dialogue with the seller to see how they approach an incorrect description…

Thanks for your help!

No problem.
Even if this box was falsely advertised with 1GbE, 100M version it is still probably the version of X96_x4 which is sold in largest numbers, because it should be around 10$ cheaper.

Yes - it was £39 in the UK. I think refurbished referred more to the fact the box had been opened and the cables weren’t tie-wrapped.

1 Like
type or paste code here

A post was merged into an existing topic: CoreELEC 19.5-Matrix_rc2 Discussion

I have the X96 X4 (S905X4) box with 4GB/32GB and 1GBit LAN. Android works fine.
With CoreELEC (19.5-Matrix_rc2) the network adapter (LAN) is not working. I can’t activate it and the box is not visible in the network. Otherwise everything looks ok
I used “sc2_s905x4_4g_1gbit” for the installation
The remote control doesn’t work either … no matter

Use 100mbit dtb instead if there is any available.

It doesn’t work with sc2_s905x4_4g either.
According to the network, the box has 1000MBit under Android. This also confirms the manufacturer’s information.

There is still a problem with the network driver

This should get you going for the remote :wink:

Maybe if you could provide the “chipset” of the embedded network adatper or a log, someone might be able to help with that also,

Maybe try dmesg | grep PHY to see if you might have a JL2101 chip. Also maybe try the 100Mb driver anyway there are other reports of mislabeled boxes.

Yes it is a JL2101 chip

JL2101-N040C is a single-port Gigabit Ethernet PHY product that supports Category 5 UTP cables to implement all physical layer functions, including 1000BASE-T, 100BASE-TX, and 10BASE-T protocols …

On my 100Mbs-only board there is an unpopulated set of chip pads that are the size of that JL2101. I’m guessing the S905X4 has an onboard PHY which is 100Mbs, and the JL2101 can be optionally added to some board designs to add Gigabit?

I guess that driver implementation may limit some firmware builds running with a JL2101 to 100Mbs (and thus using a 100Mbs cable that doesn’t support 1000Mbs - i.e. one with fewer cores - lets it run OK at 100Mbs, but with a 1000Mbs compatible cable it shows issues? I’ve seen that on other platforms in the past - where a 100Mbs switch was the solution to getting reliable connectivity with a Gigabit Phy on some OS builds)

has the same thing

i got a 4+64G(1Gbit)Version,i have tried 19.5 and 20.0 sc2_S905_x4.dtb or 1gbit version but the same result. Lan Wlan Bluetooth don’t work.Actually once lan is available(maybe 20.0 sc2_1Gbit.dtb?but when i try agin,it doesn’t work).i don’t know how to solve it,maybe return it and buy a hk1 rbox x4?it look like work well with a lower price,

There is new version of Slimboxtv out now also first one for this box, 16.4.1, but did not test it, because it is new, and there may be errors. Also not want to brick the board. Slimboxtv should be a more capable version of the original installed android, so maybe i will try it later too.

Device: S905X4 (4/32 + Dual Wifi + BT4.X + 100M)
DTB: sc2_s905x4_4g

Start from USB-flash = OK
Display resolution 3840x2160p/60 = OK
Sound = OK
Ir = OK
LAN 100Mbit = OK
WiFi 2.4 = No Adapter in system
WiFi 5 = No Adapter in system
BT = No Adapter in system
Install to Internal MMC = False

seemmc -x = Error:

Starting CoreELEC eMMC installation tool...
System is not supported: sc2_s905x4_4g!
There is NO official support by Team CoreELEC
if you continue to run this tool!
Continue? [y]: **y**
eMMC size: 0x000747c00000 [32GB]
No CoreELEC installation found on eMMC
Install in dual boot mode, CoreELEC and Android on eMMC
  Use CoreELEC data from
    [1] current used SD or USB device
    [2] existing backup on current used SD or USB device
Install in single boot mode not possible!
  No DT partition was found
Please choose one option? [1/2]: **1**
Free space of 'partition CE_FLASH': 512MB
mount: mounting /dev/loop2 on /media/CE_STORAGE failed: Invalid argument
Error running pclose on cmd: `mount -o rw,loop /dev/loop2 /media/CE_STORAGE`. Error: 255
Error executing cmd 'mount -o rw,loop /dev/loop2 /media/CE_STORAGE'
Failed to mount 'CE_STORAGE' partition!
Failed to read free space of partition 'CE_STORAGE'!
Failed to create new partition table!

I got an X96 Max Plus Ultra Android11 Smart TV Box Amlogic S905X4 4G which has the same problems both with last stable and nightly build you mentioned before:

  • no wifi, no BT, no remote support (this is the least important)
  • LAN is working though

I tried several dtb-s, it only works with sc2_s905x4_4g but lacking wifi is a dealbraker.
Can we hope for wifi support in the near future?


I have two usb:
Corsair Flash Voyager GT 32 GB - Read Speed 390 MB/s & Write Speed 80 MB/s
Patriot Supersonic Rage XT 32GB - Read Speed 180 MB/s & Write Speed 50 MB/s

Why is CoreELEC slower on Corsair Flash Voyager?

maybe it’s not the fault of the Coreelec system and the reading / writing of these two usb ones?
How did you measure speed?