CoreELEC 19.5-Matrix_rc2 Discussion

Looks like the script on the server is too smart :face_with_hand_over_mouth::
Please use this until it’s fixed:


Why remove the auto color detection? It sounded useful…

Please read the news again…

1 Like

Oh “reworked”, weird i was sure it said “removed”

Just installed on an old X96 S905x, so far no issues.

1 Like
安装的版本CoreELEC-Amlogic-ng.arm-19.5-Matrix_rc2-Generic.img.gz,dtb是sc2_s905x4_4g_1gbit.dtb,U盘写入EMMC出错,代码:No CoreELEC installation found on eMMC 
Install in dual boot mode, CoreELEC and Android on eMMC 
Use CoreELEC data from 
[1] current used SD or USB device
[2] existing backup on current used SD or USB device 

Install in single boot mode not possible! 
No DT partition was found Please choose one option? [1/2]: 1 
Free space of 'partition CE_FLASH': 512MB 
mount: mounting /dev/loop1 on /media/CE_STORAGE failed: Invalid argument 
Error running pclose on cmd: `mount -o rw,loop /dev/loop1 /media/CE_STORAGE`. Error: 255 Error executing cmd 'mount -o rw,loop /dev/loop1 /media/CE_STORAGE' 
Failed to mount 'CE_STORAGE' partition! 
Failed to read free space of partition 'CE_STORAGE'! 
Failed to create new partition table!

ceemmc won’t work on the > Android 11 firmware found on these s905x4 boxes for now, on which the system(super) and storage (userdata) partitions are newer ext4 fs either created from underlying device-mapper or stored directly on these partitions yet not readable for the 4.9 kernel CE is currectly using.

Also, to keep the new partitoon table from being reverted back, ceemmc has to remove the partitions node from dtb so the u-boot won’t “helpfully fix” the partition table, which is also not doable for these S905X4 boxes which must read the partition node in dtb instead of the partitoon table to get the location for several partitions, so removing the node will brick the box…

You could find some other ways to install to internal for these boxes not supported by anyone especially teamCE, but I don’t recommend even trying to install to emmc on S005X4 boxes for now.

1 Like

As per documentation:

After the upgrade to 19.5-Matrix_rc2 on Odroid-N2 two lines on boot screen:
[INFO] Skipped Optee TEE-Suplicant
[DEPEND] Dependency failed for Amlogic OPTEE Video Firmware Preload Service.

Is it possible to get it rid?
And what does it means?

“Optee TEE-Suplicant” service (opentee_linuxdriver.service) is skipped since the condition is not met:

And “Amlogic OPTEE Video Firmware Preload Service” (video-firmware-preload.service) failed to start since it requires opentee_linuxdriver.service:

Since these two services are only used for S905X4 for now you can simply disable these services if you’re not using a S905X4 device:

systemctl disable opentee_linuxdriver.service
systemctl disable video-firmware-preload.service
1 Like

Ops… it doesn’t work on my N2:

CoreELEC (official): 19.5-Matrix_rc2 (Amlogic-ng.arm)
MyN2:~ # systemctl disable optee_linuxdriver.service
Failed to disable unit: Unit file optee_linuxdriver.service does not exist.
MyN2:~ # systemctl disable video-firmare-preload.service
Failed to disable unit: Unit file video-firmare-preload.service does not exist.
MyN2:~ #

Sorry I’ve mistyped the service names, they should be opentee_linuxdriver.service and video-firmware-preload.service, I’ve editted my original post

nope, it doesn’t work, I mean: commands executed without any output so probably successfully but after N2 reboot still those two lines are on TV screen.

If you really need to hide messages then mask both services:

systemctl mask opentee_linuxdriver.service
systemctl mask video-firmware-preload.service

And looks like we could improve this two scripts to not show anything in any case.

1 Like

I’m getting HDMI sync issues on my Odroid N2+ with RC2.
As soon as anything is displayed at 2160p (even the UI) my projector will lose signal and resync every ~10 seconds.

I downgraded to RC1 and the issue is gone. Any ideas?

Try first do remove resolution.ini from COREELEC partition. If this does not help limit colour depth to 10 or 8 bit in kodi display expert settings.

I have found a bug an my minix u22-xj max. After playing 3D movies, the switch to the normal image mode in Kodi menu dos not work. The screen is splitted an the resolution is to big. “Disable stereoscopic 3D mode when playback ended” does not work correctly. It is in Settings / Player → Videos

Apologies if this is a known issue, but on my ODroid N2 (not plus), after the HardKernel logo splash screen shows up, I just get a blank screen on this version.

I thought it might be an issue with my hardware but I tried Armbian and everything looks OK.

Not sure how to debug this because I don’t see anything. Tried Ctrl-Alt-F1, etc. but couldn’t get anything to show up either.

Maybe start here and see if that solves it.

1 Like