X96max plus + CE boot not working

Hi all, at first I want to appreciate your work and say thank you.

I got a problem with my new X96max Plus Box 4/64 (S905x3). Stock FW is X96Max_Plus2_AI_20210928-1544. I wanted to boot CE with the sm1_s905x3_4g_1gbit.dtb (renamed to dtb.img in root). I always ended up in recovery menu. I tried other dtb, in vain.

Stock FW shows 4GB Ram and Gbit ethernet. I found out that it is a new revision with IP1001M ethernet and AM7756 Radio module for Wifi, BT.

So I thought maybe a problem with bootloader and the firmware. I downgraded to X96Max_Plus2_20200901-1005, in android wifi,bt and Ethernet not working connected to Router (1Gbit). Then I connected the box to an access-point (100Mbit) and Ethernet was ok. Seems to be a problem with drivers?!

I booted up with toothpick method and voila, CE (sm1_s905x3_4g_1gbit.dtb renamed) is there with Wifi,BT working . Only Ethernet same issue as with android above.

But cat/proc/device-tree/amlogic-dt-id showed sm1_ac213_4G.

So I flashed back the newest stock FW and tried to boot EmuElec to see if it´s a problem with sd boot and new firmware. So EmuElec bootet fine, Wifi not working, only 100Mbit Ethernet as mentioned above.

After that I tried CE with the former working sdcard (no changes), no chance with ending up in the Recovery Menu.

I don´t know what to do, wrong dtb, fake box?! Can someone please help me?

Thanks in advance

Don’t buy X96 anymore

So what‘s your suggestion?

Sell it and buy an SBC. Much more expensive than your shady box but almost zero issues you will have with a proper hw.

Your bootloader seems encrypted (hope isn’t a hastily conclusion), so maybe you need to flash another Android who will allow the usage of CE.

Send back the X96 and buy any supported box.
I would not expect much help from the CE developers

So you mean Android 8 e.g. instead of an older Android 9 fw which worked?

Could be a 8 generation Android or different custom roms - like ATV Experience. Search for this freaktab, ATV Exp forum… Something that has an unencrypted bootloader.

I thought it is an supported device…

A simple search would have done good: X96 posts

Hi, I have two boxes x96max+ and the same problem on on off that. Solution just try another sd card.
I have 4 sd cards and just one of them works on this box. I think that this box is no so bad for tha money.

X96 Max Plus (the original HW design) is supported.
You bought X96 Max Plus2 AI, which has a complete different HW setup.
see X96max plus + CE boot not working - #2 by Garcea

A new dtb is needed for this revision. The team already has it at some stage when the gigabit is working. It depends if he releases it for any release

The box is bootable with flash disk in usb 2.0. After boot use ethtool to make lan working and create and edit aurostart.sh. After that use emmc tool to put ce on emmc.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.