Xbox one Bluetooth controller

Hi guys, I can’t get my white Xbox one bluetooth controller working… . Starting from scratch, I can see any Bluetooth Device listed twice from CE… Trying to pair with my controller (obviously set on ‘pair’ mode), I always get an Input/Output error.
Lurking on the web, I found one suggestion saying to connect via SSH to the system and then push a
echo 1 > /sys/module/bluetooth/parameters/disable_ertm
Tried it without success; after the command, each Device is shown once (and not twice as before), but I still get an I/O error Trying to pair the controller.

I know most probably this is not a CE issue, but maybe someone had my same problem and was able to troubleshoot it… So, any suggestion is welcome. (I’ll try to get some log in the meantime)

I have the same problem here, nothing worked for the xbox one. (PS4 works without any workarounds)

Go ahead and help 'em Adam, I moved it to General simply because of the comment in the first post

and the only category that is for all things (even not CoreELEC related) is General :tired_face:

Sorry guys, I didn’t mean to make anyone hangry… And thanks to Poida and Adamg for the patience.
In the meantime I Tried to lurk the kodi log but what I found is not talking at all:

ERROR: ## CoreELEC Addon ## bluetooth::dbus_error_handler ## ERROR:(Input/output error)

same error for me

You are digging out an one year old thread without providing any details or logs.
You should at least trying to help us helping you.

now working in kodi and retroarch with this line in autostart echo 1 > /sys/module/bluetooth/parameters/disable_ertm and this99-terios.rules (244 Bytes) (78 Bytes)

you have to connect at every start,it does not always pair itself