Xbox One dvb-C/T/T2 Tuner on Amlogix s905 Box

Hi, i have a Tanix Tx 7 and a xBox USB-Tuner. I have some difficulties as CoreElec does not see my tuner above Version 8.95.2 and anything below sees my adapter but does not find any channels on scan (dvb-t in Germany).

Does anyone have a working solution for this?
Best regards

you need to install the dvb modules.

Not sure exactly how, but searching found this 8.90.4 and Tvheadend

1 Like

Thanx! I did that already and after it my tuner is detected. Still no services found for dvb-t2 in germany :frowning:
Meanwhile I could test it for dvb-c (unitymedia germany) and it works! I need dcb-t2 though…
Btw, i cannot install the client for tvheadend, I ger some dependency error message. Any ideas for that? Yes I know, logs…

Sorry, you can upload logs, but I’m not clever enough to interpret them.

I THINK, you can still install the client. The dependency error doesn’t stop it installing.

If, you install it, configure it with the server/backend ipaddress, I usually give it a basic username admin & password 1234.

Then type the server ip address with the default port eg to a web browser

If the server is working, then it should prompt you to follow the wizard.

I have found in the past, that the SD channels will be scanned, but I have to rescan a couple more to get all of the T2 (HD) channels

I assume you have got a good tv signal?


Which modules need I install?


I have a xbox tuner, but I can’t remember which one I used.

It would be far quicker to try each of these, rather than waiting for a reply

Hello, i have connect xbox one tuner to my ki pro s905 box with coreelec 9.0.3 and the tvheadend do not show this tuner.

I have tried too with Beelink GT king and i got the same result.

Anything to try?

Have you selected dvb from latest kernel?

where i must select it?

I have choose the three options dvb in coreelec module drivers

That’s one of those three, is the tuner connected directly to one of the usb ports?

Yes, directly.
I have check it in mecool ki pro (in this box, tvheadend only list internal tuner and digibit sat ip) and beelink GT king (only list digibit sat ip)

Can you SSH to the box with the tuner connected and run the command lsusb and post the result here?

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0781:5591 SanDisk Corp. Ultra Flair
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I think, it is not detected

I just tried again in my GT King and it’s detected. I’m on last nightly. Try again to choose drivers from latest kernel in the CoreELEC module driver’s. Reboot and run lsusb again.

I think the tuner is broken. I have received it today and it was sealed, it is stranger.

In th PC, i connect the tuner and it not detect too. i will buy other