1080p HDR problem, 10 bit video stutter

Hi guys,
Happy new year and all :slight_smile:

I’m on n5max 905x2, 9.2.1 stable, and have two issues with recent files I tried to play.

  1. 1080p HDR not playing as HDR:
    sample file: https://www78.zippyshare.com/v/heosC2td/file.html
    my TV detects this as HDR and plays it in HDR mode (using usb stick).
    but CoreELEC plays this with washed out colors (both movie itself and the OSD icons).

  2. video stutters:
    sample file: https://www78.zippyshare.com/v/CrdJEXiw/file.html
    it’s a sample from a 10bit animated file. I get stutters from 00:32 to 00:45.
    PC plays this just fine (using VLC).

another small question.
while testing the 10bit/hdr issue, I used “cat /sys/class/amhdmitx/amhdmitx0/config”, and I’ve noticed that it says “Colour depth: 10-bit” no matter which file is played, 8 bit or 10 bit.
is this a problem?

thanks!

I also noticed that issue with 1080p HDR files. As a workaround you can remove 1080p modes from the whitelist so 1080p will be upscaled to 4K. Upscaled to 4K 1080p files play as HDR.

1 Like
  1. Works fine in HDR here. Make sure that the file is played with hardware decoding. If it is, then your TV may not support HDR at 1080P.
  2. That is a 10-bit H264 file, which can not be hardware decoded, meaning it uses software decoding. The S905X2 is not powerful enough for FullHD software decoding.
  3. 10-bit color depth is normal, CE will always select the highest supported color depth.
2 Likes

thanks for the quick reply.

  1. file is played with hardware decoding. how come the tv’s internal player IS able to play it in HDR? do you mean the problem the tv is having is with input signal which is 1080p HDR?
  2. thanks, wasn’t aware of this.
  3. don’t fully understand this. if the video is 8-bit, what is being expanded to 10-bit?

I’m not sure why the TV can play it from the internal player in HDR, but not through CE, but I’ve tried it on my LG TV and can confirm that it’s working perfectly fine for me. Although I am using a new build, maybe try the latest nightly and see if there’s any difference.

In regards to 8/10 bit thing. Nothing is being expanded. The signal to the TV is 10 bits, but the video is still 8 bits. There is no dithering going on.

1 Like

it’s very strange, but now suddenly the HDR file plays fine, I get HDR indicator on my TV, and the colors look good.
don’t really know what I did, I had a lot of testing going on yesterday involving rebooting the streamer, restarting kodi, sending various cec commands, editing cron jobs, restarting the TV/AVR (which I did plenty times before and it didn’t change the outcome).
is there any debug log I can take now, and the next time it doesn’t work, to help understand the reason?

8 bit video is often played at 10 bits or 12 bits. The 8 bits take the 8 highest bits and the 2 or 4 least significant bits that take you to 10 or 12 bits are just padded with zeroes usually.

1 Like

Greetings,
I have the same problem with 1080p HDR content describet in post. My 1080p HDR content is wahsed out, 4K HDR is OK everytime. I tried sample in this topic and it is the same problem. Only workaround I have found it is force coreelec with “Limit display colour depth to 8-bit” - then 1080p HDR content is OK. Tried at AML S912 and AML S905X2 with same problem.
When “Limit display colour depth to 8-bit” is Disabled (picture washed out) log here: http://ix.io/284t
When “Limit display colour depth to 8-bit” is Enabled (picture ok) log here: http://ix.io/284w

1 Like

Cannot post more than two links. So here is photo of my “Samsung UE65NU8002” TV:
When “Limit display colour depth to 8-bit” is Disabled (picture washed out) Photo of TV: https://photos.app.goo.gl/vzQsyLd5r4igrQ729
When “Limit display colour depth to 8-bit” is Enabled (picture ok) Photo of TV: https://photos.app.goo.gl/f5E6rrExuH6Cn2k87
You can see big difference in KODI UI colors (blue) too when playing sample.

1 Like

I also found that the correct display of 1080p HDR also can be done by enabling “Use 4:2:2 color subsampling” setting in “Settings - System - Coreelec”.

Edit: Is it a bug or feature? I think, it is not right behavior, or may I send it somewhere else? Btw what do you mean is better atm - enable 8-bit or 4:2:2?

1 Like

I still see the issue in the nightlies (1080p HDR content is washed out).
can someone look at this?
what logs can I provide?
@ mlebeda
like you, I also found that enabling “Use 4:2:2 color subsampling” setting in “Settings - System - Coreelec” makes 1080p HDR be detected successfully by the TV.
I’m not sure what the consequences are though. don’t know what this options does.

There are no issues with HDR that we are aware of.

I understand that, but I’m seeing the issue for sure :slight_smile:
maybe it’s my setup, or my device, so is there anything I can do to get this resolved?

Not that I can think of. Could be a bad cable or the TV needs the ultra deep color option enabled on the hdmi input the box is connected to.

a bad cable doesn’t really makes sense, 4K HDR works fine…
also that option (HDMI UHD Color) is already activated.
and since I’m not alone in this issue I’m pretty sure it’s not my TV or my cables, but the box itself (magicsee n5 max - s905x2) or something in CE regarding this hardware…

1 Like

It is a known issue with Samsung TVs requiring the use of 4:2:2 chroma in order to work right at 4K resolutions. It also happens with some AVRs.
I’ve not heard of any such issues with LG TVs, I have an LG B7 and it works fine with 4K and 1080P HDR content without any issues, without 4:2:2 chroma, but it also works fine with this option enabled. In my setup it makes no difference. It’s possible that your model is different, and requires some tweaking to get it to work, I don’t even know what TV and AVR models you have.

it’s samsung nu7100, and yamaha v383.
but I don’t have any issues with 4k hdr. it’s only 1080p hdr content that I need to use that option with.

Could be a TV or AVR thing, I’m not sure.
Whatever the case may be, the CE side works fine.

For me - Coreelec box is connected directly to TV. And as mentioned before - I have only 1080p 10-bit HDR problem. Everything else works fine.

Sounds like a compatibility issue with Samsung TVs.
In Samsung TVs 4:2:2 chroma option is often needed for things to work as expected.