19.0-Matrix Discussion

That’s great news. Thank you for the response.

Really? That’s curious, yet hopefull. Same thing is mentioned in this thread a couple of times. Both my s905x boxes are t95n, and in the discourse thread a95x and mecool boxes are mentioned.

Here’s a debug log for the I am legend trailer: http://ix.io/2RGl

@raytestrak Can you SSH into your device and run ce-debug and paste here the link you receive?

That would be: http://ix.io/2RGO

As I mentioned before. This can happen if you use Multi PCM audio device but your device is not capable. Sre the files with aac audio using more than one channel? Are you using an AVR or Soundbar? What is your GUI resolution?
The default audio device changed at least 2 times between CE releases. Check if it’s still the correct one.

I checked the audio device, I even tried all the others, even tried it with and without passthrough.

Box is hooked up to 7.2 receiver which is capable of playing anything. I had no issues playing the files on 9.2.6 and also no issues playing them on my s905x3 box.

My default audio device is HDMI, passthrough is enabled and all the capabilities boxes are checked.

As Ray said you need to choose HDMI Multi Ch PCM and in channels 7.1 should be selected. Without this settings you don’t receive multichannel AAC via HDMI.
May be try to reboot after this settings.

If you select HDMI then for AAC you should select only 2.0 and not any other values.

Thanks, it’s quite the puzzle. PCM and 7.1 is still a no go for some AAC files for me, but HDMI and 2.0 seems to work for everything. According to Kodi and my receiver it’s multichannel, but I’ll have to investigate that, the fraunhofer sample I posted is only coming from my fronts. But still, it’s better than kodi crashing :slight_smile: I’m assuming that due to passthrough dts-ma en truehd are still multichannel?

I also have three 4k hevc mp4 files with ac3 that cause coreelec to reboot on my s905x boxes. These also play fine on s905x3, but I’ve never tried them on my amlogic 9.2.6, only on amlogic-ng. Can’t reproduce it with other files. 1080p ac3 plays fine, 4k hevc mp4 sample file without audio plays fine.
Also can’t find any reference to it in any of my kodi logs, it appears to crash before it has the chance to log anything.

On my Odroid N2 many files play with stutters after updating. I’m considering to go back to 9.2.6. I’m running off eMMC.

Check adjust display refresh rate settings if they are set correctly. Should be on start / stop
If doesn’t solve upload full log and ce-debug output

1 Like

The adjust display refresh rate is set correctly. Here are the logs after playing a file with stuttering.
Full log: http://ix.io/2RKJ ce-debug log: http://ix.io/2RKL

2021-03-05 11:12:22.851 T:4700     INFO <general>: [WHITELIST] Searching the whitelist for: width: 1920, height: 800, fps: 25.000, 3D: false
2021-03-05 11:12:22.852 T:4700     INFO <general>: Display resolution ADJUST : 1920x1080 @ 59.94 - Full Screen (16) (weight: -38237668521001120432128.000)

Not correct refresh rate switch for this file
Strange, it should work the same way as in 9.2.6.
Could you try to update to nightly and check if issue still exist
If still exist, then please upload 15-30 seconds sample of this file to test

At this point I don’t feel like troubleshooting much. Clean 19 on eMMC I still had the problem, haven’t tried nightly. Meanwhile I went back to 9.2.6 which does not have any issues for me.

On my Beelink GT1 mini there is a problem with the video playing. twitches appear in the video. Whitelist - All resolutions supported by the TV are enabled. Adjust the screen refresh rate - start/stop.
Log - http://ix.io/2RKX
Ce - debug log - http://ix.io/2RKY

I don’t see 23.98Hz frame rate and 59.94 Hz too in your whitelist. You should enable it too

But my television doesn’t support it. Should i allow it?

If you see it in Whitelist list then you TV supports it. Yes, you should select them.

23.98Hz frame rate and 59.94 Hz added to whitelist - reboot - play video - the problem persists

Please show me both logs again