19.0-Matrix Discussion

I like it. Hovewer, I’d preffer to get channel list, not timeline as a result, because timeline is slower to load. Or, it should be possible to configure

It seems I fixed it, I had a few minor conflicts with startup.xml in my skin

I can make all the logs with the old and corrected startup.xml file
perhaps it will be of use to someone in the future.


Looks like anything containing AAC as audio codec won’t play on s905x. I have 2 s905x boxes, both won’t play AAC with amlogic-ng, which they did with 9.2 amlogic builds. My s905x3 box does, is this a know issue, or can I provide debug logs?

Can you provide a sample. Or link to one?

You are using LPCM Audio

Quick question as I’m pretty noobish about this stuff. Does dropping S905 extend to all the devices with similar chipsets? For instance I’m currently using a S905X2 box and I don’t know if I should even try 19.0.
Either way congratulations and thanks to the devs for the amazing continued support on this project over the years!

This sample doesn’t cause Kodi to crash, but it doesn’t play audio either.

This one shows the same behavior as my media:

After a couple of seconds it crashes/

S905 means gxbb. Amlogic is stupid with naming. S905 only and S912 (gxm). S905X,D,W,X2,X3 still supported.


Out of curiosity I played both samples on both my boxes, and they both play fine with video and audio. The trailer does not crash the box. First box is a x96 max plus with a s905x3. Second box is an mxq pro plus with a s905x.

Please share a log, here in vim1 S905x the files play normally.

That’s great news. Thank you for the response.

Really? That’s curious, yet hopefull. Same thing is mentioned in this thread a couple of times. Both my s905x boxes are t95n, and in the discourse thread a95x and mecool boxes are mentioned.

Here’s a debug log for the I am legend trailer: http://ix.io/2RGl

@raytestrak Can you SSH into your device and run ce-debug and paste here the link you receive?

That would be: http://ix.io/2RGO

As I mentioned before. This can happen if you use Multi PCM audio device but your device is not capable. Sre the files with aac audio using more than one channel? Are you using an AVR or Soundbar? What is your GUI resolution?
The default audio device changed at least 2 times between CE releases. Check if it’s still the correct one.

I checked the audio device, I even tried all the others, even tried it with and without passthrough.

Box is hooked up to 7.2 receiver which is capable of playing anything. I had no issues playing the files on 9.2.6 and also no issues playing them on my s905x3 box.

My default audio device is HDMI, passthrough is enabled and all the capabilities boxes are checked.

As Ray said you need to choose HDMI Multi Ch PCM and in channels 7.1 should be selected. Without this settings you don’t receive multichannel AAC via HDMI.
May be try to reboot after this settings.

If you select HDMI then for AAC you should select only 2.0 and not any other values.

Thanks, it’s quite the puzzle. PCM and 7.1 is still a no go for some AAC files for me, but HDMI and 2.0 seems to work for everything. According to Kodi and my receiver it’s multichannel, but I’ll have to investigate that, the fraunhofer sample I posted is only coming from my fronts. But still, it’s better than kodi crashing :slight_smile: I’m assuming that due to passthrough dts-ma en truehd are still multichannel?

I also have three 4k hevc mp4 files with ac3 that cause coreelec to reboot on my s905x boxes. These also play fine on s905x3, but I’ve never tried them on my amlogic 9.2.6, only on amlogic-ng. Can’t reproduce it with other files. 1080p ac3 plays fine, 4k hevc mp4 sample file without audio plays fine.
Also can’t find any reference to it in any of my kodi logs, it appears to crash before it has the chance to log anything.

On my Odroid N2 many files play with stutters after updating. I’m considering to go back to 9.2.6. I’m running off eMMC.

Check adjust display refresh rate settings if they are set correctly. Should be on start / stop
If doesn’t solve upload full log and ce-debug output

1 Like