19.0-Matrix Discussion

The issue with Confluence can be addressed by refreshing the addons, then it will update automatically.

I doubt a kernel log will be helpful. In my guess I assume it is an API limitations but without kodi logs it’s hard to say

Khadas VIM3L HTPC. Clean install. No remote working. When I enable BL301.BIN Injection and reboot device CoreELEC not start. Black screen. Not starting and Android. Indicates no signal on the TV screen.

Currently Khadas updated the bootloader blobs and injection is not compatible anymore. It’s know and will be discovery next days/weeks. Just use a older firmware until it’s solved. @Vasco knows what version was last working one.

You need to enable the IR remote by choose the correct toml file like the guide shows:

Only the second line should be needed.

I also launched the matrix on the X96 Max Plus
this box has no problems, it’s s905x3

However, on the Beelink GT-Minia 1 (a) they are

I am sending the log below.


But if I understand correctly Power ON / Off will not work until it is fixed?

Just updated my N2 from 9.2.6 to Matrix 19 and all appears to be working well. Good job guys.

There’s one thing that’s different in Matrix. In 9.2.x there was no TV Groups shown under TV even though they were not hidden in the Group Manager.

These groups now appear in Matrix under TV. Yes you can hide them, but why the different behaviour.


Something to ask on the Kodi forum I guess.
I kinda like it.

Seems like it’s an added “feature”


As I said just go with a older firmware for now till it’s fixed. I think march 2019 should work.

Yes it is. And there.are a couple more.

Too bad selecting “hide group” will not remove the channel group widget(s) from the home screen.

I just noticed you are right.
I was hiding one group (radio) that worked fine.

If I try to hide one or more tv groups they still stick.
Wondering whether this is intended or a bug, since my backends have radio disabled. Maybe you can’t hide it if the backend pushes the group(s).

Just asked the question on Github, do not know if I will get an answer.

It seems to me that the user should have the option. So leaning to a bug :wink:

Sounds like a bug to me too, but like you I think it maybe controlled from the backend.

Good news: It would seem that installing the build you posted has fixed the resolution issues I was having.
Thanks heaps :grinning:

Thank you for confirmation. Fix will be added in tomorrow nightly

Also upload ce-debug output please.
And output of command cat /storage/.kodi/userdata/addon_data/service.coreelec.settings/oe_settings.xml|paste
Possible something wrong in settings file

I would refrain from using bl_301 in VIM3L. It’s being worked on.