3GB Ram X98 Pro and CoreElec

#1

Hi Guys,

I am complety new to this CoreElec.
So if anyone can help me with the following it would be very nice.
At home i have the following device.
X98 Pro 32GB
Quad Core ARM Cortex A53 64-bit tot 2GHz
Amlogic S912
3GB DDR3
32 GB ROM.

Currently the device is running on :
LibreElec 8.1.9 and Kodi 17.4

I want to upgrade to CoreElec now.
I tried to download the correct image for it by using the download helper.
The X98pro is not listed.
If i choose the generic S912 there is noo option to select RAM / VARIANT.
Also it does not show the DTB file i need.

Can someone help me out?

Thanks in advance!

!

0 Likes

#2

The relevant Hardware specs to determine which dtb.img will HOPEFULLY boot your box are the soc / amount of ram and the ethernet speed.
In your case
S912 (soc)
3GB (ram amount)
Ethernet Speed 1000 / 100 ???

gxm_q201_3g_1gbit.dtb

gxm_q201_3g.dtb

1 Like

#3

Gigabit Ethernet, 802.11 b/g/n Dual Band Wi-Fi (2.4GHz/ 5.8GHz)

0 Likes

#4

After you burn the image
Insert it back into your PC / Mac and you will see a folder with Device trees.
Open it and copy the above .dtb to the root of the SD Card.
Rename it to dtb.img

0 Likes

#5

Just downloaded the image and used Rufus to burn it on a class 10 sd card…
Copied en renamed the Tree file and putted in in the root of the sd card.
Putted the card in the X98 pro and used the tooth pick method.
Push and hold the reset button and reconnect the power.
The screen keeps black and after some time time the LiebreElec logo once popped up in stead of the CoreElec logo. So the toothpick method does not work on my X98 Pro.
I will try to perform the action by using a USB stick with the software.

0 Likes

#6

I didn’t realise you have LibreElec installed internal.
Is that correct ???
Don’t use Toothpick Recovery.
Just insert SD Card.
Then boot.

0 Likes

#7

Android has been removed and LibreElec has been put on the box.
So now I want to get rid of this LibreElec and use CoreElec.
I already tried to just boot with the SD card in the X98 but still LibreElec keeps showing up… So wondering what is wrong…

0 Likes

#8

Power on LE.
Insert SD CE
Choose Reboot.
What happens ??
@Jeff4u2day
Also try the following.In that order. Remember to rename them.
You don’t have to toothpick restore. Just replace the dtb.img in the SD Card and see if it boots.
gxm_q201_3g.dtb

gxm_q201_c300_pro.dtb

gxm_q201_3g_c400_plus.dtb

0 Likes

#9

Hello.

After quite some attempts it’s now working.
The system booted and the CoreElec logo popped up.
After a few seconds the screen turned black and nothing.
I reebooted the box several times and everytime the same problem.
The problem was the Logitech dongle i use to connect my keyboard.
One i used this in a different usb port the system fully booted.
There is only one problem now. When i want to connect the box wired it does not give me a ip adress. When i select wireless networks it works.
Is there an option to still use my wired connection?
The option wired is enabled in the system.

0 Likes

#10

Remember to take note of the dtb.img that booted the box.
You need to enable full debug log.
https://wiki.libreelec.tv/how_to/provide_logfile#tab__via_ssh
Enable and reboot.
Then run ssh commands.
Kodi logs and System logs.
post the log urls here.

0 Likes

#11

Is it nog only caused by using a wrong tree file that it does not show an ip ?
When i select wireless i can connect to wireless networks and get an IP

0 Likes

#12

Without the logs we won’t know what loads on boot.
There’s been issues with some of these s912 Gigabit boxes dtb.img

1 Like