8.90.5 - Mini M8S II - remote controller doesn't work


I can’t get my remote control to work with the latest release.

Mini M8S II 2G/16G
gxl_p212_2g.dtb copied from the device_tree folder as dtb.img to the root of the sd
booted using the toothpick method

When Kodi starts, the remote simply does not work.

Tried the following guide:

…and copied one of the pre made config files from this source:



# table m8s, type: NEC 0x8051 KEY_POWER 0x804d KEY_MUTE 0x8056 KEY_VOLUMEDOWN 0x804e KEY_VOLUMEUP 0x8053 KEY_HOME 0x801b KEY_BACK 0x80bd KEY_REWIND 0x80bb KEY_FASTFORWARD 0x8009 KEY_INFO 0x8011 KEY_STOP 0x8054 KEY_EPG 0x804f KEY_CONFIG 0x8026 KEY_UP 0x8025 KEY_LEFT 0x8027 KEY_RIGHT 0x8028 KEY_DOWN 0x800d KEY_ENTER 0x8049 KEY_MENU 0x8052 KEY_CONTEXT_MENU 0x8031 KEY_1 0x8032 KEY_2 0x8033 KEY_3 0x8034 KEY_4 0x8035 KEY_5 0x8036 KEY_6 0x8037 KEY_7 0x8038 KEY_8 0x8039 KEY_9 0x8030 KEY_0 0x8058 KEY_PLAYPAUSE 0x8044 KEY_DELETE


meson-ir        *     m8s

stopped kodi and eventlircd
checked with “ir-keytable -t” if the scancodes matches with those of the pre made config file (m8s) and they all did.

Loaded the config with “ir-keytable -a /storage/.config/rc_maps.cfg -s rc0” and restarted eventlircd and kodi.

The remote control still doesn’t work.

What am I doing wrong?

Did you copy this files or you copy content of this file?
If content, than check via Notepad++ for correct EOL Conversion, must be Unix (Edit->EOL Conversion)
Also you have to be sure that correct dtb.img device-tree used.

You are not using the correct remote configuration.
Try the T95N one from here.
Or create your own.

I’ve copied the file, not only its content.
Now I opend the file with vi and saw that the encoding is wrong (DOS/CRLF). So the pre made config file was the issue here. The keymap file (m8s) is ok. Only the rc_maps.cfg is faulty.

Now it works.

As I said in the OP, I’ve checked every single ir code. It was the pre made rc_maps,cfg. You can check it yourself.


I have a T95N, it’s a Mini M8S II clone (even has that on a small label on the box) and that config file works just fine, because I made it myself with the remote that came with the box.
Maybe something corrupted the file between the time I posted it and when it ended up in that dropbox folder. Glad you got it working.

The config files came from this user:

Hey @canna would you mind sharing those files? I do have the exactly same issue and I’m not able to solve it, I’ve tried many configurations and none of them is working. I’ve also done the EOL Conversion and that didn’t help either.

  1. You have to be sure that correct dtb.img device-tree used from img.gz or tar file and not from different internet source.
    If still doesn’t work after 1st step than upload files somewhere to check what is wrong

I have tried many of them I have Mini M8S II and from what I’ve read I should use gxl_p212_2g but none of them will boot. The only img that’ll boot is from LibreElec that came with it as it was stated that for S905X I don’t need to change the dtb file.

I hope you renamed it to dtb.img?
For CE you need to use only device tree from CE tar.gz and not from LE. And of course you need to rename correct dtb file to dtb.img

Is the title incorrect, or are you using an alpha CE build?

I´ve a Mini M8S II with CoreElec working with no problem.
For DTB.img you need to use one of this:

Mini M8S II         1G/16G               S905X        gxl_p212_1g
Mini M8S II         2G/16G               S905X        gxl_p212_2g

For remote use the zipMini M8S II.zip (721 Bytes)