9.0.0 Discussion


#24

I have the same problem as @crazyturk . I am using the same cable as before for versions below 9.0.0. Sometimes the screen just resets for no rhyme or reason even when nothing is playing.


#25

Thanks a lot for this change.


#26

Solution is the same, you need good cable.


#27

The default value for everything above 3840x2160@30Hz is 4:2:0, which is the official HDMI standard. Some newer LG TVs had problems with it, why this switch was implemented.
Everything equal or below 3840x2160@30Hz is using 4:4:4.


#28

Good job guys. Working great on my 905x. BTW final kodi 18.1 was released today


#29

Thanks.The source of the error was caused by the AVR video output.I changed 1080P24Hz to 1080P and it worked fine.


#30

Hi,

I’m new to CoreElec: installed version 8.99.1 when Kodi 18 became final and updated it to 8.99.2 on my Minix U9-H.

Regarding the potential HDMI cable issue some people might now have, I think it would be due to the higher color subsampling ability… I haven’t installed CoreElec 9 with the option to choose the subsampling (can’t find the option on version 8.99.2) yet, but this is what I can clearly state bandwidth wise, based on the signal passing through my HDFury Vertex splitter:

UHD HDR video sample:

  • Android 6, Kodi 17.6: 4K59.933 4:2:0 BT2020 10b HDR 371MHz

  • CoreElec 8.99.2, Kodi 18: 4K59.933 4:2:2 BT2020 12b HDR 593MHz

Notice that with the CoreElec subsampling type and bit depth, the pixel clock approaches the 600MHz HDMI 2 limit… which requires very good (HDMI Certified) cables to pass the signal reliably.

So if there’s an option to choose a lower color subsampling type, this could help some people.

My 2 cents…

Regards,

W.

PS: thanks to all the devs and contributors for such a customisable product.


#31

thank you to all Devs for this stable release !


#32

Update to the latest release, 9.0, resolved that issue.


#33

We really need a HDFury Vertex for our main HDR developer. Those are damn expensive though.


#34

I found the cause for this behaviour. I updated to 9.0 my 8.99.2 installation on which I had OpenVFD v.1.0.3.0.
Made a new istall from scrach. From CE repo installed OpenVFD v.1.0.2.0 (the only one offered) Everything worked fine except my problem with Indicators on OpenVFD.
Updated OpenVFD (from saved zip) to v.1.0.3.0 and I started to get errors described above. Freezing during making backups and during file copy/move.

Then I uninstalled OpenVFD v.1.0.3.0 and everything went back to normal No more freezing during backup or file copy/move…, strange :slight_smile:


#35

The HDFury Integral 2 is USD 50 cheaper than the Vertex and has the same capabilities, minus the OLED display.

But the detailed signal info is available when connected to a Windows PC or via the Android / Apple App if you add the Bluetooth dongle.

Great stuff for troubleshooting or extending the lifespan of an AVR which lacks HDCP 2.2 or 4K compatibility, for example… and so much more compatibility wise if needed.

W


#36

@Walky, In CoreELEC 9 the default chroma subsampling is 4:2:0 for > 30 Hz content which uses less bandwidth than 4:2:2, yet you have the option to use 4:2:2 over 4:2:0 in settings.

People that want to play 4K 60fps HDR samples should swap their cheap HDMI cable which are included with the box for a better one


#37

Actually I found out after more testing that my new SD card (Sandisk Ultra 32Gb) was the cause for all problems.
CE 9.0 + OpenVFD 1.0.3.0 works OK installed on my USB stick.


#38

Hello, I recently built a libreelec for the old meson6 box (g02ref / g18ref_th2). Thanks to the example of the dvb-avl I have succeeded successfully to build a DVB-S2 driver. The box is amazingly fast with the sdcard image. Unfortunately, libreelec discontinued support for meson6 (kernel 3.10.108). Will you continue to support meson6 (Wetek_Play)? In any case, I will now build a CoreElec for the box and try to customize OpenVFD for meson6.


#39

CoreELEC has never supported the Meson6 SoC.
We only support S905/X/D/W and S912 at this point.


#40

Thanks guys, just updated from my manual build and it’s running great!


#41

Can you guys recompile inputstreamadaptive to latest version 2.3.15? I’d love to test that new YouTube 4K integration :wink:


#42

As far as I know this only works with Kodi 18.1.


#43

That’s fine, I’ll wait :wink: