9.0.1 Discussion


#1

Please use this thread for general 9.0.1 discussion


Upgrade to 9.0.1 breaks PVR
CoreELEC 9.0.1
9.0.0 Discussion
#2

fixed reboot issue (missing syscall 385)

Ha. Didn’t even encounter it until I tried the manual update and typed ‘reboot’ to see the system hang. :slight_smile:

TVHeadend HTSP client is incompatible with what’s shipped(?). Thoughts?


#3

IPTV Archive pvr client stopped working. Update/enable attempts rises kodi.binary.instance.pvr version error (not found 5.10.4).


#4

Yep, I can confirm that TVHeadend HTSP client gets reported as incompatible and deactivated. The InputStreamAdaptive addon is CE repo is also outdated.


#5

Clear Packages. I always do this before update.
Mine updated immediately after the 9.0.1 UPDATE.

H96Pro H3 Dongle S905X 2GB/16GB


#6

Thanks for the update, pvr got disabled after update.
Had to force-update the version bump. After that pvr worked.

This releases has some important fixes (Kodi). Great work!


#7

I always do that. Maybe it hasn’t propagated yet or what?

I checked my storage/.kodi/addons/packages and it’s empty. I have also forced multiple times to refresh the repo and confirmed that repo version itself is latest 9.0.2. Still no updates both when checking repo updates and single addon update. Not sure what’s going on.

TVHeadend HTSP reports dependency issue with kodi.binary.instance.pvr like @vevs reported.


#8

Same here, no luck with IPTV pvr…


#9

It seems the default layout (keymap) has changed, which leaves me unable to assign the context menu button anymore on a xiami remote.
Only key that this happen to is the ‘hamburger’ button on the lower right.

Can the previous default keymap layout please be restored for this button?

/edit; noticed that the ‘home’ key is now context by default en context menu is now inert.
I fail to see the logic in that and hope it can be corrected. Thanks!


#10

Second box manually updated Tanix TX3 Mini S905W 2GB/16GB

Same successful update as 9.0.1 Discussion


#11

No idea what kind or type of remote a xiami is.


#12

In addons left menu “Check for updates”


#13

You are right, my Chinese is not what it used to be.
I meant Xiaomi, this one.

It used to work ootb on versions before this one, wrxtasy did a great job on that.


#14

Just checking for updates did not work for me (tvmosaic).
I had to manually update in Addon PVR client settings to the new version.

Just in case someone else encounters this.


#15

Nothing is changed, still can’t install IPTV pvr :frowning:
ERROR: CAddonInstallJob[pvr.iptvsimple]: The dependency on kodi.binary.instance.pvr version 5.10.4 could not be satisfied.


#16

Not even when you go to Addons-My Addons-[Your pvr client]- Do manual update ?
Hm, that (and only that) worked for me


#17

I’ve deleted it for clean install attempt.


#18

Looked into /usr/share/kodi/addons/kodi.binary.instance.pvr/addon.xml and see version="5.10.3" :thinking:
Dunno how @kostaman made succesfull update…


#19

@vevs: Can you post kodi debug log when you are attempting to install addon?

Version 5.10.4 was with CoreELEC 9.0. Do you even use 9.0.1?


#20

Hello @vpeter, glad to see you again! I’ve posted log-message above, here once again:

2019-02-27 14:53:18.888 T:3487708016 ERROR: CAddonInstallJob[pvr.iptvarchive]: The dependency on kodi.binary.instance.pvr version 5.10.4 could not be satisfied.

Addon version 3.5.5.2, and according to addons.xml it really requires the 5.10.4 version of kodi.binary.instance.pvr, which is not in place in current CoreElec build.