9.0.1 Discussion


#21

Post whole debug file. Not just one line.

pvr.iptvarchive is already at version 3.5.7.2!


#22

Here you are.


#23

IPTV Simple (not Archive) showed as 3.5.7.2 and it also can’t be installed with the same error.


#24

You are using wrong (old) repository from CE 9.0. Now with CE 9.0.1 different repository is used.
Try to refresh CoreELEC repository (Context menu ‘Check for updates’).

What you get by command
cat /usr/share/kodi/addons/repository.coreelec/addon.xml
cat /storage/.kodi/addons/repository.coreelec/addon.xml


#25

@Atreyu this change was made by @wrxtasy link, not sure why but I have asked.


#26

Same version, but different URL :flushed: Manual deletion of /storage/.kodi/addons/repository.coreelec solved the problem! Strange why “Check for updates” didn’t work (tried many times either with reboot and no). Thank you @vpeter!


#27

Did you made /storage/.kodi/addons/repository.coreelec manually? Or it was made by CE itself or did you install any repository.coreelec zip?


#28

My installation has a long update history :slight_smile: But no, i definitely didn’t create it manually and didn’t make manual repo install, as i can recall…


#29

Same Problem here after update. Can’t enable pvr simple addon. I got another issue, the coreelec custom definitions dissapear.


#30

This only happens if you downgraded CE and used some custom repository.corelec in
/storage/.kodi/addons/repository.coreelec


#31

Yes, I’ve downgraded CE once, but without doing something manually with the repo. Anyway, thanks for the clarification, mine problem is solved now!


#32

Thank you, @adamg. Missed that.
I think it might have someting to do with the layout of the majority of new models of this type of remote; i believe that hard assigment of the bottom right key is actually pause now, which is what it does by default during live play. It would be great to be able to adjust the ‘hamburger’ key again. If not, i could live without or i will have to resort to my own keymap in storage again :wink:


#33

Problem solved following the same process as @vevs


#34
  • improved subtitle rendering

Does this refer to the subtitle stuttering issue or something else?


[soved] All pvr incompatible after latest update
#35

If the second command above returs output, should that file, or the direcotry ‘repository.coreelec’ be deleted to ensure proper autoupdating?

I have two Tanix 3 mini devices here and I updated both from the same downloaded file.
One of them apparently removed the file while the other did not.

What is the best course of action?


#36

As @Ray wrote just remove folder /storage/.kodi/addons/repository.coreelec.
rm -rf /storage/.kodi/addons/repository.coreelec


#37

Thanks for the confirmation.


#38

@Atreyu Quote wrxtasy (he updated the code): No time tonight - ask if he has custom Keymaps enabled. They will need to be reset to default…


#39

Thank you, @Ray.
First thing i did was remove any customizations.

The issue is, that the new ‘context menu’ button is assigned to play/pause now, which is a un-recognized code on this Xiaomi model (in a context where nothing is playing).

What i did for now, is create some custom keymap files in \storage as described by wrxtasy:
https://forum.kodi.tv/showthread.php?tid=317011&pid=2645790#pid2645790
Then, i used the previous evmap as below, all fine now :wink:

Name: xiaomibtremote.evmap

contents:
KEY_POWER = KEY_MUTE
KEY_COMPOSE = KEY_STOPCD
KEY_HOME = KEY_HOME
KEY_BACK = KEY_EXIT


#41

@fs_candido: No, this folder should be removed because there is no reason to exists. And problem will arrive again on next update if still there.