9.0.1 Discussion

You need to follow all of the instructions!

Ignore the 9.0.2 as that is just the repository version and it has been at this for over 6 months now and is irrelevant.

I followed… only uninstalled yesterday and today with your instructions “install failed” twice

A final confirmation.
I tested several times and this is all it takes.

@anon88919003 out of interest: will not updating pvr api bring possible regressions in this area?

maybe an updating problem with the server… when I had a problem like this (2x) every time was confirmed a problem on the CE site

when almost every your plugin trying to update I get “installation failed” now

even tried to re update

My crystal ball is broken today, please provide a log so I can see what your doing.

Many users have confirmed no problem after following these simple and concise instructions.

confirmed, very probably a problem of the connection to your servers


  1. your SSH commands
    rm -rf /storage/.kodi/addons/packages
    rm -rf /storage/.kodi/addons/repository.coreelec
  2. update nightly
  3. update stable
  4. able to install/update PVR client

@bylderup provided very probably the only complex solution to the problem, thank you!

I’m having problems with my plugins.

I sorted the PVR-problems with deleting two repository-folders, but I’m still having issues with video plugins YLE Areena and CMore. I can browse list of videos, but playback fails.

Here’s the log: http://ix.io/1CDV

I tryed this now serval times, but i get still the same error.
I see the requested URL in the Kodi.log. So i try to use wget on the odroid-c2 with the url in the log, which failed.
wget works. And it has downloaded the zip file.
This confuses me :confused:

2019-03-05 18:51:08.580 T:3987919728   ERROR: Requested path https://addons.coreelec.org/9.0/Amlogic/arm/pvr.zattoo/pvr.zattoo- not found in known repository directories
2019-03-05 18:51:08.580 T:3987919728   ERROR: CAddonInstallJob[pvr.zattoo]: failed to resolve addon install source path
2019-03-05 18:51:54.832 T:3530552176   ERROR: Requested path https://addons.coreelec.org/9.0/Amlogic/arm/inputstream.adaptive/inputstream.adaptive- not found in known repository directories
2019-03-05 18:51:54.832 T:3530552176   ERROR: CAddonInstallJob[inputstream.adaptive]: failed to resolve addon install source path
2019-03-05 18:52:14.924 T:3530552176   ERROR: GetDirectory - Error getting

DBraun, post kodi debug log. I think I saw same messages not long back.


what do you mean with “i tried this…” ?
The procedure from AdamG or the solution I have posted ?
The log file part you have posted is pointing exactly to the problem which should be solved if you try my workaroud as posted above. It is confirmed as working in postings at kodinerds also.

We bumped PVR API versions to make PVR addons work correctly after adding IPTV Archive support. A user suggested a better way to implement archive support, so we have now reverted back to following Kodi PVR API. This has caused these issues that some people now have. We thought it’s better to deal with this problem right now and get everything sorted out before Kodi bumps their PVR API, which would have caused even more problems down the line.

I have the same problem with a Samsung TV. No issues with previous auto-updated versión (I don’t know wich number was, I think it was on the 8.9x.y branch) Solved with this workaround, after reboot too. Is there any open discussion for this problem? I can provide my debug logs…

I am trying to download CoreELEC-Amlogic.arm-9.0.1-Generic.img, download starts but it stops somewhere at around 5<30%, might be an issue with servers?

This is dl link I am trying: https://github.com/CoreELEC/CoreELEC/releases/download/9.0.1/CoreELEC-Amlogic.arm-9.0.1-Generic.img.gz

Anybody more success?
Thank you, PDlissue

This file downloads fine here.

Hi! I’ve been using CoreElec on a 2gb LePotato for a few months now and it’s amazing. But, on 9.0.1, the whole thing freezes after a few minutes of playing any video and I can’t find why. I tried playing locally, through a network, different resolutions, etc. and I could only solve it by installing the LibreElec 9.0.1 image, which works well but doesn’t support 3840x2160p. So I’d like to stick with CoreElec. Is there any way I could help to find the bug?


It worked for me also after several minutes. Thanks for quick response!

@DBraun either you are using an old version of CoreELEC or you have not followed the instructions in my previous post here as according to the log you provided, the URL that your device is trying to get the addons from is wrong.

Hi again! I ran some tests and the crash happens when the CPU reaches 100% usage, the whole system freezes and I can only shut it off from the power supply. Logs don’t show any error, probably because it’s not Kodi related. Thank you in advance!

Thanks for your explanation. Appreciated.

Could be a bad power supply or high temperature that cause instability and lead to a lockup of the system.